Skip Menu |
 

This queue is for tickets about the POE-Test-Helpers CPAN distribution.

Report information
The Basics
Id: 60210
Status: resolved
Priority: 0/
Queue: POE-Test-Helpers

People
Owner: Nobody in particular
Requestors: zlo [...] zlo.nu
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 1.07
Fixed in: (no value)



Subject: Module::Build version dependency too strict
Download (untitled) / with headers
text/plain 158b
Nothing major, but I just wanted to let you know that the dependency on 0.3601 of Module::Build seems not really needed. It works fine with 0.280801 here. ;-)
Download (untitled) / with headers
text/plain 394b
On Tue Aug 10 07:00:55 2010, marcolz wrote: Show quoted text
> Nothing major, but I just wanted to let you know that the dependency on > 0.3601 of Module::Build seems not really needed. It works fine with > 0.280801 here. ;-)
Is this an issue for you? The current Build.PL/Makefile.PL is created by Dist::Zilla automatically. If this poses as a problem for you, reopen the ticket and I'll fix that manually.
CC: Marc Olzheim <zlo [...] zlo.nu>
Subject: Re: [rt.cpan.org #60210] Module::Build version dependency too strict
Date: Wed, 11 Aug 2010 08:58:24 +0200
To: Sawyer X via RT <bug-POE-Test-Helpers [...] rt.cpan.org>
From: Marc Olzheim <zlo [...] zlo.nu>
Download (untitled) / with headers
text/plain 848b
On Wed, Aug 11, 2010 at 02:51:25AM -0400, Sawyer X via RT wrote: Show quoted text
> On Tue Aug 10 07:00:55 2010, marcolz wrote:
> > Nothing major, but I just wanted to let you know that the dependency on > > 0.3601 of Module::Build seems not really needed. It works fine with > > 0.280801 here. ;-)
> > Is this an issue for you? > > The current Build.PL/Makefile.PL is created by Dist::Zilla automatically. > > If this poses as a problem for you, reopen the ticket and I'll fix that > manually.
Well, it is an issue in the sense that a build produces a warning and my autobuild will not package anything which outputs warnings, resulting in manual work. So I do not think it's something worth releasing a new version for, but maybe you will consider changing it in a possible future release. ;-) Thanks for your time, Marc (maintainer of perl on the iphone)
Download (untitled) / with headers
text/plain 450b
On Wed Aug 11 02:58:36 2010, marcolz wrote: Show quoted text
> > Well, it is an issue in the sense that a build produces a warning and my > autobuild will not package anything which outputs warnings, resulting in > manual work. So I do not think it's something worth releasing a new > version for, but maybe you will consider changing it in a possible > future release. ;-)
Well, then I would consider it an issue. :) I'll have a release out soon enough! Sawyer.
CC: zlo [...] zlo.nu
Subject: Re: [rt.cpan.org #60210] Module::Build version dependency too strict
Date: Wed, 11 Aug 2010 09:03:43 +0200
To: Sawyer X via RT <bug-POE-Test-Helpers [...] rt.cpan.org>
From: Marc Olzheim <zlo [...] zlo.nu>
Download (untitled) / with headers
text/plain 631b
On Wed, Aug 11, 2010 at 03:00:51AM -0400, Sawyer X via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=60210 > > > On Wed Aug 11 02:58:36 2010, marcolz wrote:
> > > > Well, it is an issue in the sense that a build produces a warning and my > > autobuild will not package anything which outputs warnings, resulting in > > manual work. So I do not think it's something worth releasing a new > > version for, but maybe you will consider changing it in a possible > > future release. ;-)
> > Well, then I would consider it an issue. :) > > I'll have a release out soon enough!
Ok, great, thanks for you effort! Marc
Download (untitled) / with headers
text/plain 359b
On Wed Aug 11 03:03:50 2010, marcolz wrote: Show quoted text
> > Well, then I would consider it an issue. :) > > > > I'll have a release out soon enough!
> > Ok, great, thanks for you effort! > > Marc
I've just uploaded POE::Test::Helpers 1.09 which doesn't use a Build.PL file nor does it require Module::Build. Thanks for the report, and have a great day! :) Sawyer.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.