This queue is for tickets about the Authen-Passphrase CPAN distribution.

Report information
The Basics
Id:
59917
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
ANSGAR [...] cpan.org
Cc:
CARNIL [...] cpan.org
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: [PATCH] Use Digest::SHA instead of Digest::SHA1
Date: Sat, 31 Jul 2010 20:17:49 +0900
To: bug-Authen-Passphrase@rt.cpan.org
From: Ansgar Burchardt <ANSGAR@cpan.org>
Hi, the attached patch changes Authen::Passphrase::MySQL41 to use the Digest::SHA module instead of Digest::SHA1. Digest::SHA is part of the standard perl distribution since perl v5.9.3 so this reduces the number of external dependencies by one. Please consider applying it for the next release. Regards, Ansgar
--- libauthen-passphrase-perl.orig/lib/Authen/Passphrase/MySQL41.pm +++ libauthen-passphrase-perl/lib/Authen/Passphrase/MySQL41.pm @@ -46,7 +46,7 @@ use Authen::Passphrase 0.003; use Carp qw(croak); -use Digest::SHA1 qw(sha1); +use Digest::SHA qw(sha1); our $VERSION = "0.007"; @@ -166,7 +166,7 @@ =head1 SEE ALSO L<Authen::Passphrase>, -L<Digest::SHA1> +L<Digest::SHA> =head1 AUTHOR
Thanks, accepted. Will be in the next release.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.