Skip Menu |
 

This queue is for tickets about the FCGI CPAN distribution.

Report information
The Basics
Id: 59887
Status: open
Priority: 0/
Queue: FCGI

People
Owner: Nobody in particular
Requestors: roeyalmog [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.71
Fixed in: (no value)



Subject: Perl FCGI not working with mod_fcgid + apache 2.2.15 on windows xp
Download (untitled) / with headers
text/plain 732b
To reproduce: Install apache 2.2.15 with mod_fcgid on Windows XP SP3 Install ActiveState apache + FCGI module Configure apache to run the perl example script in the mod_fcgid it is not working You'll get [Thu Jul 29 11:26:07 2010] [warn] [client 127.0.0.1] (OS 109)The pipe has been ended. : mod_fcgid: get overlap result error [Thu Jul 29 11:26:07 2010] [error] [client 127.0.0.1] Premature end of script headers: foo.pl in the logs I double check everything including: The #!/usr/bin/perl.exe line at the foo.pl perl script file it points to where perl is installed on my computer The mod_fcgid is loaded when running the script as plain cgi it works When I turned to the older mod_fastcgi it works just fine
Subject: Re: [rt.cpan.org #59887] Perl FCGI not working with mod_fcgid + apache 2.2.15 on windows xp
Date: Mon, 02 Aug 2010 23:40:43 +0200
To: bug-FCGI [...] rt.cpan.org
From: Christian Hansen <christian.hansen [...] mac.com>
Download (untitled) / with headers
text/plain 1.3k
30 jul 2010 kl. 21.47 skrev Roey via RT: Show quoted text
> Fri Jul 30 15:47:42 2010: Request 59887 was acted upon. > Transaction: Ticket created by roeya > Queue: FCGI > Subject: Perl FCGI not working with mod_fcgid + apache 2.2.15 on > windows xp > Broken in: 0.71 > Severity: Critical > Owner: Nobody > Requestors: roeyalmog@gmail.com > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=59887 > > > > To reproduce: > > Install apache 2.2.15 with mod_fcgid on Windows XP SP3 > Install ActiveState apache + FCGI module > Configure apache to run the perl example script in the mod_fcgid it > is not working
I couldn't find a example script in trunk (http://svn.apache.org/repos/asf/httpd/mod_fcgid/trunk ), we would be thankful if you could provide us with the script that failed. Show quoted text
> You'll get > > [Thu Jul 29 11:26:07 2010] [warn] [client 127.0.0.1] (OS 109)The pipe > has been ended. : mod_fcgid: get overlap result error > [Thu Jul 29 11:26:07 2010] [error] [client 127.0.0.1] Premature end of > script headers: foo.pl >
And the httpd.conf you are using. Show quoted text
> in the logs > > I double check everything including: > The #!/usr/bin/perl.exe line at the foo.pl perl script file it points > to where perl is installed on my computer > The mod_fcgid is loaded > > when running the script as plain cgi it works > When I turned to the older mod_fastcgi it works just fine >
Subject: Re: [rt.cpan.org #59887] Perl FCGI not working with mod_fcgid + apache 2.2.15 on windows xp
Date: Tue, 3 Aug 2010 12:38:21 +0300
To: bug-FCGI [...] rt.cpan.org
From: "Roey Almog (Infoneto Ltd)" <almog [...] infoneto.co.il>
Download (untitled) / with headers
text/plain 2.1k
Christian Hi, Thank you for your response Here is a FCGI script that causes the error: #!/usr/bin/perl.exe use FCGI; my $count = 0; my $request = FCGI::Request(); while($request->Accept() >= 0) { print("Content-type: text/html\r\n\r\n", ++$count); } My perl is installed at c:\usr I have attached my conf file. my apache for this test was installed on c:\temp\apache2 I tested it with both apache 2.2.15 from http://www.apache.org/ and 2.2.16 from http://www.apachelounge.com/ Thanks for your help Roey On Tue, Aug 3, 2010 at 12:40 AM, Christian Hansen via RT < bug-FCGI@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=59887 > > > > 30 jul 2010 kl. 21.47 skrev Roey via RT: >
> > Fri Jul 30 15:47:42 2010: Request 59887 was acted upon. > > Transaction: Ticket created by roeya > > Queue: FCGI > > Subject: Perl FCGI not working with mod_fcgid + apache 2.2.15 on > > windows xp > > Broken in: 0.71 > > Severity: Critical > > Owner: Nobody > > Requestors: roeyalmog@gmail.com > > Status: new > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=59887 > > > > > > > To reproduce: > > > > Install apache 2.2.15 with mod_fcgid on Windows XP SP3 > > Install ActiveState apache + FCGI module > > Configure apache to run the perl example script in the mod_fcgid it > > is not working
> > I couldn't find a example script in trunk ( > http://svn.apache.org/repos/asf/httpd/mod_fcgid/trunk > ), we would be thankful if you could provide us with the script that > failed. > >
> > You'll get > > > > [Thu Jul 29 11:26:07 2010] [warn] [client 127.0.0.1] (OS 109)The pipe > > has been ended. : mod_fcgid: get overlap result error > > [Thu Jul 29 11:26:07 2010] [error] [client 127.0.0.1] Premature end of > > script headers: foo.pl > >
> > And the httpd.conf you are using. > >
> > in the logs > > > > I double check everything including: > > The #!/usr/bin/perl.exe line at the foo.pl perl script file it points > > to where perl is installed on my computer > > The mod_fcgid is loaded > > > > when running the script as plain cgi it works > > When I turned to the older mod_fastcgi it works just fine > >
> > >
Download httpd.conf
application/octet-stream 17.6k

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.