This queue is for tickets about the Net-OpenID-Consumer CPAN distribution.

Report information
The Basics
Id:
59251
Status:
resolved
Priority:
Low/Low

People
Owner:
crew [...] cs.stanford.edu
Requestors:
jettero [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
  • 1.100099_001
  • 1.11



Subject: NOC only checks <head> tags for <link> tags.
I can't authenticate any users of myopenid because they don't contain their <link> tags in a <head> tag. :( -- If riding in an airplane is flying, then riding in a boat is swimming. 115 jumps, 47.9 minutes of freefall, 91.6 freefall miles.
That's not what I see. Seems that their HTML is fine. Should I close this bug? http://bradfitz.myopenid.com/ view source: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> <html> <head > <title> http://bradfitz.myopenid.com/ </title> <link rel="stylesheet" href="http://www.myopenid.com/static/reset-fonts-grids-base.css" type="text/css"> <link rel="stylesheet" href="http://www.myopenid.com/static/screen.css" type="text/css"> <link rel="openid.server" href="http://www.myopenid.com/server" /> <link rel="openid2.provider" href="http://www.myopenid.com/server" /> <link rel="stylesheet" href="http://www.myopenid.com/static/idpages/idpage.css" /> <script type="text/javascript"> function imageUploadHandler(submit_button_id) { submit_button = document.getElementById(submit_button_id); submit_button.disabled = false; } </script> </head> <body > On Sat Jul 10 10:55:58 2010, JETTERO wrote:
Show quoted text
> I can't authenticate any users of myopenid because they don't > contain their <link> tags in a <head> tag. :( > >
On Sat Jul 10 10:55:58 2010, JETTERO wrote:
Show quoted text
> I can't authenticate any users of myopenid because they don't > contain their <link> tags in a <head> tag. :( > >
Are you sure this is the problem? TypePad.com is using Net::OpenID::Consumer and I was able to successfully sign in to that with my myopenid.com OpenID identifier, and as Brad noted their HTML looks fine to me.
On Sat Jul 10 14:20:47 2010, MART wrote:
Show quoted text
> On Sat Jul 10 10:55:58 2010, JETTERO wrote:
> > I can't authenticate any users of myopenid because they don't > > contain their <link> tags in a <head> tag. :( > > > >
> > Are you sure this is the problem?
Yes, I'm quite sure. It appears they've added the head tags back. I wonder if it was some live edit or something. I was having the problem on two machines and patched around the problem by changing this # # # # # # # # return $self->_fail("no_head_tag", "Couldn't find OpenID servers due to no head tag") # # # # # # # # unless $doc =~ m!<head[^>]*>(.*?)</head>!is; # # # # # # # # my $head = $1; To this: my $head = $doc; But if I was simply mistaken, that's fine too. Either way, this ticket isn't a keeper. -Paul -- If riding in an airplane is flying, then riding in a boat is swimming. 114 jumps, 47.2 minutes of freefall, 90.4 freefall miles.
I believe this is fixed in Net-OpenID-Consumer-1.11 If you want to try it out, please make sure you've also installed the latest Net-OpenID-Common. Feel free to re-open (or start a new ticket) if I'm mistaken about this. Thanks for the report and sorry this took so long to get to... - Roger Crew (new co-maintainer as of a few weeks ago)


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.