Skip Menu |
 

This queue is for tickets about the Class-MOP CPAN distribution.

Report information
The Basics
Id: 59201
Status: rejected
Priority: 0/
Queue: Class-MOP

People
Owner: Nobody in particular
Requestors: warren [...] shutterstock.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Missing requirement
Date: Thu, 8 Jul 2010 11:21:16 -0400
To: bug-class-mop [...] rt.cpan.org
From: Warren Melnick <warren [...] shutterstock.com>
Download (untitled) / with headers
text/plain 269b
When attempting to install Class::MOP, the tests require Package::Stash to be present but it is not listed as a prerequisite. Thought you would like to know. Regards, W -- Warren Melnick Systems Programmer Shutterstock 60 Broad Street, 30th Floor NY, NY 10004
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 10:25:46 -0500
To: Warren Melnick via RT <bug-Class-MOP [...] rt.cpan.org>
From: Jesse Luehrs <doy [...] cpan.org>
Download (untitled) / with headers
text/plain 285b
On Thu, Jul 08, 2010 at 11:21:39AM -0400, Warren Melnick via RT wrote: Show quoted text
> When attempting to install Class::MOP, the tests require Package::Stash to be present but it is not listed as a prerequisite.
From Makefile.PL: requires 'Package::Stash'; How exactly is it breaking for you?
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 11:29:42 -0400
To: bug-Class-MOP [...] rt.cpan.org
From: Warren Melnick <warren [...] shutterstock.com>
Download (untitled) / with headers
text/plain 2.5k
Here is a short snippet: /usr/bin/make -- OK Running make test /usr/bin/perl "-Iinc" "-MModule::Install::ExtraTests" "-e" "Module::Install::ExtraTests::__harness('Test::Harness', 0, 'xt/author', '', '', 0, 'blib/lib', 'blib/arch')" t/*.t t/000_load................................NOK 1 # Failed test 'use Class::MOP;' # at t/000_load.t line 7. # Tried to use 'Class::MOP'. # Error: Can't locate Package/Stash.pm in @INC (@INC contains: [...] .) at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP/Package.pm line 9. # BEGIN failed--compilation aborted at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP/Package.pm line 9. # Compilation failed in require at (eval 38) line 3. # ...propagated at /usr/lib/perl5/5.8.6/base.pm line 85. # BEGIN failed--compilation aborted at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP/Module.pm line 14. # Compilation failed in require at (eval 37) line 3. # ...propagated at /usr/lib/perl5/5.8.6/base.pm line 85. # BEGIN failed--compilation aborted at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP/Class.pm line 25. # Compilation failed in require at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP.pm line 19. # BEGIN failed--compilation aborted at /root/.cpan/build/Class-MOP-1.03/blib/lib/Class/MOP.pm line 19. # Compilation failed in require at (eval 4) line 2. # BEGIN failed--compilation aborted at (eval 4) line 2. t/000_load................................ok 18/0Bareword "Class::MOP::get_all_metaclasses" not allowed while "strict subs" in use at t/000_load.t line 67. Bareword "Class::MOP::get_all_metaclass_instances" not allowed while "strict subs" in use at t/000_load.t line 74. Execution of t/000_load.t aborted due to compilation errors. # Tests were run but no plan was declared and done_testing() was not seen. t/000_load................................dubious Test returned status 255 (wstat 65280, 0xff00) t/001_basic...............................Can't locate Package/Stash.pm in @INC (@INC contains: On Jul 8, 2010, at 11:25 AM, Jesse Luehrs via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=59201 > > > On Thu, Jul 08, 2010 at 11:21:39AM -0400, Warren Melnick via RT wrote:
>> When attempting to install Class::MOP, the tests require Package::Stash to be present but it is not listed as a prerequisite.
> > From Makefile.PL: > > requires 'Package::Stash'; > > How exactly is it breaking for you? >
-- Warren Melnick Systems Programmer Shutterstock 60 Broad Street, 30th Floor NY, NY 10004
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 10:32:48 -0500
To: Warren Melnick via RT <bug-Class-MOP [...] rt.cpan.org>
From: Jesse Luehrs <doy [...] cpan.org>
Download (untitled) / with headers
text/plain 247b
On Thu, Jul 08, 2010 at 11:30:13AM -0400, Warren Melnick via RT wrote: Show quoted text
> Here is a short snippet: > > <snip>
This is too short to figure out what's going on - you've stripped out the actual important parts (the Makefile.PL invocation and @INC).
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 11:32:49 -0400
To: bug-Class-MOP [...] rt.cpan.org
From: Warren Melnick <warren [...] shutterstock.com>
Download (untitled) / with headers
text/plain 696b
Perhaps you misunderstood what I said. If the module requires Package::Stash, shouldn't cpan somehow know that it is a requirement so that it is installed first? Regards, W On Jul 8, 2010, at 11:25 AM, Jesse Luehrs via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=59201 > > > On Thu, Jul 08, 2010 at 11:21:39AM -0400, Warren Melnick via RT wrote:
>> When attempting to install Class::MOP, the tests require Package::Stash to be present but it is not listed as a prerequisite.
> > From Makefile.PL: > > requires 'Package::Stash'; > > How exactly is it breaking for you? >
-- Warren Melnick Systems Programmer Shutterstock 60 Broad Street, 30th Floor NY, NY 10004
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 10:36:11 -0500
To: Warren Melnick via RT <bug-Class-MOP [...] rt.cpan.org>
From: Jesse Luehrs <doy [...] cpan.org>
Download (untitled) / with headers
text/plain 478b
On Thu, Jul 08, 2010 at 11:33:02AM -0400, Warren Melnick via RT wrote: Show quoted text
> Perhaps you misunderstood what I said. If the module requires Package::Stash, shouldn't cpan somehow know that it is a requirement so that it is installed first?
Yes, and what I'm saying is that we're already doing this properly. If cpan isn't picking it up for you, then it's likely something misconfigured on your end. I have no idea what it could be though, since you didn't give enough information.
Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 11:43:29 -0400
To: bug-Class-MOP [...] rt.cpan.org
From: Warren Melnick <warren [...] shutterstock.com>
Download (untitled) / with headers
text/plain 137.4k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/html 146.7k

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #59201] Missing requirement
Date: Thu, 8 Jul 2010 10:52:59 -0500
To: Warren Melnick via RT <bug-Class-MOP [...] rt.cpan.org>
From: Jesse Luehrs <doy [...] cpan.org>
Download (untitled) / with headers
text/plain 494b
On Thu, Jul 08, 2010 at 11:44:18AM -0400, Warren Melnick via RT wrote: Show quoted text
> Here is a longer snippet: > > <snip>
I still don't see Makefile.PL output in there. If the Makefile.PL is actually not being run, that would be a reason that the dependency isn't getting picked up (maybe try "rm -rf ~/.cpan/build/). Secondly, your @INC is waaaay messed up, and I wouldn't be surprised if it was causing problems on its own, but not sure what to do about that, since I'm not sure what would cause that.
Download (untitled) / with headers
text/plain 132b
Haven't heard any more about this in quite a while, and Class::MOP is no longer maintained on its own any more, so closing this now.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.