Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Software-License CPAN distribution.

Report information
The Basics
Id: 59116
Status: rejected
Priority: 0/
Queue: Software-License

People
Owner: Nobody in particular
Requestors: JNW [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Software::License requires MRO::Compat
Download (untitled) / with headers
text/plain 145b
Makefile.PL should list MRO::Compat in BUILD_REQUIRES this helps the testsuite to survive. I forgot to preserve the exact error message. sorry.
... and it also requires Sub::Exporter
Download (untitled) / with headers
text/plain 511b
I see absolutely no evidence of this. ~$ cpanm --look Software::License Fetching http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Software-License-0.101620.tar.gz ... OK Entering /Users/rjbs/.cpanm/work/1278442179.9944/Software-License-0.101620 with /opt/local/bin/zsh ~/.cpanm/work/1278442179.9944/Software-License-0.101620$ ack -a Sub::Exp ~/.cpanm/work/1278442179.9944/Software-License-0.101620$ ack -a MRO::Compat What evidence did you gather that suggested that either of these were required? -- rjbs
Download (untitled) / with headers
text/plain 1.3k
This is what happens to me: + make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/basic................. # Failed test 'require Software::License::Perl_5;' # at t/basic.t line 8. # Tried to require 'Software::License::Perl_5'. # Error: Can't locate MRO/Compat.pm in @INC (@INC contains: /usr/src/packages/BUILD/Software-License-0.101620/blib/lib /usr/src/packages/BUILD/Software-License-0.101620/blib/arch /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl . /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/vendor_perl/5.10.0/Data/Section.pm line 9.
Download (untitled) / with headers
text/plain 263b
On Tue Jul 06 15:06:45 2010, JNW wrote: Show quoted text
> This is what happens to me: >
and this: # Failed test 'require Software::License::Perl_5;' # at t/basic.t line 8. # Tried to require 'Software::License::Perl_5'. # Error: Can't locate Sub/Exporter.pm in @INC
Download (untitled) / with headers
text/plain 527b
On Tue Jul 06 15:09:38 2010, JNW wrote: Show quoted text
> On Tue Jul 06 15:06:45 2010, JNW wrote:
> > This is what happens to me: > >
> and this: > # Failed test 'require Software::License::Perl_5;' > # at t/basic.t line 8. > # Tried to require 'Software::License::Perl_5'. > # Error: Can't locate Sub/Exporter.pm in @INC
Maybe I am pulling an unwanted indirect dependency? Click on the 'succeeded' links to see my full buildlogs: https://build.opensuse.org/package/show?package=perl-Software-License&project=home:jnweiger:perl
Download (untitled) / with headers
text/plain 374b
note that the stack trace you provided ends with: /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/vendor_perl/5.10.0/Data/Section.pm line 9. Data::Section requires those things, and you somehow installed it without installing its prerequisites. Data-Section correctly declares its prereqs. -- rjbs
Right you are. My Requires were BuildRequires. Thanks and sorry. -JW


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.