Skip Menu |
 

This queue is for tickets about the Devel-LeakTrace CPAN distribution.

Report information
The Basics
Id: 59027
Status: new
Priority: 0/
Queue: Devel-LeakTrace

People
Owner: Nobody in particular
Requestors: KTHAKORE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.05
Fixed in: (no value)



Subject: Fails to build with glib2.0 due to switch to pkg-config
Download (untitled) / with headers
text/plain 141b
glib2.0 has switched to pkg-config. It breaks Build.PL. I have included my Build.PL. Maybe make it check for both glib-config and pkg-config?
Subject: Build.PL
Download Build.PL
text/x-perl 592b
use strict; use Module::Build; die "You don't seem to have glib installed (couldn't run glib-config --version), stopping\n" unless `pkg-config --version glib-2.0`; my $build = Module::Build->new( module_name => "Devel::LeakTrace", dynamic_config => 1, license => 'perl', requires => { 'Module::Build' => '0.19', # xs 'Test::More' => 0, }, extra_compiler_flags => ''.`pkg-config --cflags glib-2.0`, extra_linker_flags => ''.`pkg-config --libs glib-2.0`, create_makefile_pl => 'passthrough', ); $build->create_build_script;


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.