This queue is for tickets about the Catalyst-Devel CPAN distribution.

Report information
The Basics
Id:
58433
Status:
resolved
Priority:
Low/Low

People
Owner:
bobtfish [...] bobtfish.net
Requestors:
volker.voit [...] googlemail.com
Cc:
AdminCc:

BugTracker
Severity:
Unimportant
Broken in:
1.27
Fixed in:
(no value)



Subject: missing dependency
After installing Catalyst::Devel I ran perl catalyst.pl My::Something (yes, I am reading the book :) After that I used prove -l t/* and it said that Test::Pod::Coverage 1.04 is missing. ___ OS: Windows 7 Ultimate 64 perl: strawberry-perl This is perl 5, version 12, subversion 0 (v5.12.0) built for MSWin32-x86-multi-thread I had perl freshly installed and the only thing I did with it was cpan install local::lib cpan install Catalyst::Devel
Hiya. This isn't really a missing dependency as the generated tests are entirely optional. In fact, they don't run unless the TEST_POD environment variable is set, and I've adjusted the generated application skeleton in commit e83023a to check this first, before skipping due to the dependency. I'd be entirely happy with a patch which moved these tests to xt/ (using the new Module::Install author tests feature) if you'd be interested in contributing that? I'm going to close this as not a bug however.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.