Skip Menu |
 

This queue is for tickets about the Smolder CPAN distribution.

Report information
The Basics
Id: 58257
Status: open
Priority: 0/
Queue: Smolder

People
Owner: Nobody in particular
Requestors: SvenDowideit [...] home.org.au
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.51
Fixed in: (no value)



Subject: default value for hostname should be simpler
Download (untitled) / with headers
text/plain 1.1k
I cpan installed Smolder (onto debian stable), and then (with the assumption that the defaults would be good enough, ran 'smolder' with no arguments. The machine churned for a short while, and then spat me out to the commandline again - with no info/warnings/errors. so - nothing to suggest that (or which) settings where missing, nothing to tell me that it hadn't quietly spawned a background task, nothing. after way too much mucking around (mostly because i had a cold and thus was too braindead to do any critical work) I eventually ran it from the debugger, only to find out that the bind was failing.... tada, adding --host localhost to the command, and suddenly _something_ worked - still no feedback on the console, but at least the process still runs. so, at minimum, it'd be good to change the default to 'localhost' so that someone that does a quick non-configured test run doesn't get a 'there are defaults, but something is broken, i wonder what is wrong with my OS' reaction, and , perhaps it'd be useful to have a little more info? (now to actually try to work out how to use it for foswiki, and if I can have it run as cgi from a hosted apache) Cheers Sven
Download (untitled) / with headers
text/plain 139b
It seems that with the recent changes, executing smolder with no arguments actually runs it correctly. -- Close the world, txEn eht nepO.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.