Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the DateTime-Format-Strptime CPAN distribution.

Report information
The Basics
Id: 57895
Status: resolved
Priority: 0/
Queue: DateTime-Format-Strptime

People
Owner: Nobody in particular
Requestors: zefram [...] fysh.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Error while parsing version number
Date: Thu, 27 May 2010 09:36:27 +0100
To: bug-DateTime-Format-Strptime [...] rt.cpan.org
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 2.7k
Got this from an attempt to install DateTime::Format::Strptime: {{{{{ Running install for module 'DateTime::Format::Strptime' Running make for D/DR/DROLSKY/DateTime-Format-Strptime-1.2000.tar.gz Fetching with LWP: http://cpan.etla.org/authors/id/D/DR/DROLSKY/DateTime-Format-Strptime-1.2000.tar.gz WARNING: This key is not certified with a trusted signature! Primary key fingerprint: 2E66 557A B97C 19C7 91AF 8E20 328D A867 450F 89EC Signature for /root/.cpan/sources/authors/id/D/DR/DROLSKY/CHECKSUMS ok Checksum for /root/.cpan/sources/authors/id/D/DR/DROLSKY/DateTime-Format-Strptime-1.2000.tar.gz ok Will not use Archive::Tar, need 1.00 DateTime-Format-Strptime-1.2000 DateTime-Format-Strptime-1.2000/META.yml DateTime-Format-Strptime-1.2000/Changes DateTime-Format-Strptime-1.2000/README DateTime-Format-Strptime-1.2000/MANIFEST DateTime-Format-Strptime-1.2000/Makefile.PL DateTime-Format-Strptime-1.2000/SIGNATURE DateTime-Format-Strptime-1.2000/LICENSE DateTime-Format-Strptime-1.2000/Build.PL DateTime-Format-Strptime-1.2000/t DateTime-Format-Strptime-1.2000/t/004_locale_defaults.t DateTime-Format-Strptime-1.2000/t/001_load.t DateTime-Format-Strptime-1.2000/t/003_every.t DateTime-Format-Strptime-1.2000/t/008_epoch.t DateTime-Format-Strptime-1.2000/t/006_locales.t DateTime-Format-Strptime-1.2000/t/005_croak.t DateTime-Format-Strptime-1.2000/t/007_edge.t DateTime-Format-Strptime-1.2000/t/002_dates.t DateTime-Format-Strptime-1.2000/t/009_regexp.t DateTime-Format-Strptime-1.2000/lib DateTime-Format-Strptime-1.2000/lib/DateTime DateTime-Format-Strptime-1.2000/lib/DateTime/Format DateTime-Format-Strptime-1.2000/lib/DateTime/Format/Strptime.pm DateTime-Format-Strptime-1.2000/xt DateTime-Format-Strptime-1.2000/xt/pod-spell.t DateTime-Format-Strptime-1.2000/xt/pod.t DateTime-Format-Strptime-1.2000/xt/001_all_locales.t DateTime-Format-Strptime-1.2000/xt/pod-coverage.t DateTime-Format-Strptime-1.2000/xt/kwalitee.t WARNING: This key is not certified with a trusted signature! Primary key fingerprint: 289E 9EB5 50BD 9C89 15E3 5FAF 2203 02B1 5F2A BD12 CPAN.pm: Going to build D/DR/DROLSKY/DateTime-Format-Strptime-1.2000.tar.gz Creating new 'MYMETA.yml' with configuration results Creating new 'Build' script for 'DateTime-Format-Strptime' version '1.2000' Building DateTime-Format-Strptime DROLSKY/DateTime-Format-Strptime-1.2000.tar.gz ./Build -- OK Running Build test Error while parsing version number in file '/usr/share/perl/5.10/Test/Harness.pm' The version of your Test::Harness is only 'undef', you need at least '2.62'. Please upgrade your Test::Harness. Running Build install make test had returned bad status, won't install without force }}}}} However, Test::Harness is actually of a perfectly good version: $ grep -w VERSION /usr/share/perl/5.10/Test/Harness.pm $VERSION =head1 VERSION $VERSION = '3.21'; $ -zefram
Subject: Re: [rt.cpan.org #57895] Error while parsing version number
Date: Thu, 27 May 2010 07:39:29 -0500 (CDT)
To: Zefram via RT <bug-DateTime-Format-Strptime [...] rt.cpan.org>
From: Dave Rolsky <autarch [...] urth.org>
Download (untitled) / with headers
text/plain 1012b
On Thu, 27 May 2010, Zefram via RT wrote: Show quoted text
> Error while parsing version number in file '/usr/share/perl/5.10/Test/Harness.pm' > The version of your Test::Harness is only > 'undef', you need at least '2.62'. Please upgrade your Test::Harness. > Running Build install > make test had returned bad status, won't install without force > }}}}} > > However, Test::Harness is actually of a perfectly good version: > > $ grep -w VERSION /usr/share/perl/5.10/Test/Harness.pm > $VERSION > =head1 VERSION > $VERSION = '3.21'; > $
Hmm, there's no explicit Test::Harness prereq for this module. I think something in your set of toolchain modules is off. Do you have an old version of Module::Build or something like that? That doesn't seem lkely with 5.10 though. -dave /*============================================================ http://VegGuide.org http://blog.urth.org Your guide to all that's veg House Absolute(ly Pointless) ============================================================*/
Subject: Re: [rt.cpan.org #57895] Error while parsing version number
Date: Thu, 27 May 2010 14:44:40 +0100
To: "autarch [...] urth.org via RT" <bug-DateTime-Format-Strptime [...] rt.cpan.org>
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 552b
autarch@urth.org via RT wrote: Show quoted text
>Hmm, there's no explicit Test::Harness prereq for this module. I think >something in your set of toolchain modules is off. Do you have an old >version of Module::Build or something like that?
No, it's reasonably recent on this machine (0.3601). Strangely, clearing the CPAN build dir and restarting the mammoth install that this was a part of has now successfully installed DT:F:S. I can't reproduce the problem. So possibly it got solved by a different part of the install, but I'm at a loss to see what. -zefram


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.