Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the SGML-Parser-OpenSP CPAN distribution.

Report information
The Basics
Id: 57886
Status: rejected
Priority: 0/
Queue: SGML-Parser-OpenSP

People
Owner: Nobody in particular
Requestors: john [...] smadness.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in:
  • 0.99
  • 0.994
Fixed in: (no value)



Subject: installing on SnowLeopard fails run with Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Download (untitled) / with headers
text/plain 1.7k
The module doesn't seem to work on Mac OS X SnowLeopard. Once a valid install of Fink is found to install the OpenSP libraries, I've added this line to the WriteMakefile function in Makefile.PL to point to that location: INC => '-I/sw/include', # e.g., '-I/usr/include/other' Then in the OpenSP.xs file I must comment out these lines due to a build failure: // if (_hv_fetch_SvTRUE(hv, "show_error_numbers", 18)) // pk.setOption(ParserEventGeneratorKit::showErrorNumbers); After that, the module actually installs fine onto SnowLeopard. However, it does not run (and fails 'make test' as well) due to a missing symbol: Can't load '/Library/Perl/5.10.0/darwin-thread-multi-2level/auto/SGML/Parser/OpenSP/OpenSP.bundle' for module SGML::Parser::OpenSP: dlopen(/Library/Perl/5.10.0/darwin-thread-multi-2level/auto/SGML/Parser/OpenSP/OpenSP.bundle, 1): Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE Referenced from: /Library/Perl/5.10.0/darwin-thread-multi-2level/auto/SGML/Parser/OpenSP/OpenSP.bundle Expected in: flat namespace in /Library/Perl/5.10.0/darwin-thread-multi-2level/auto/SGML/Parser/OpenSP/OpenSP.bundle at /System/Library/Perl/5.10.0/darwin-thread-multi-2level/XSLoader.pm line 67. at /Library/Perl/5.10.0/darwin-thread-multi-2level/SGML/Parser/OpenSP.pm line 18 Compilation failed in require at /Applications/Validator-SAC.app/Contents/Resources/validator/htdocs/check.pl line 63. BEGIN failed--compilation aborted at /Applications/Validator-SAC.app/Contents/Resources/validator/htdocs/check.pl line 63. SnowLeopard is using Perl v5.10.0 for darwin-thread-multi-2level This is an intel i386 machine. Darwin ***.com 10.2.0 Darwin Kernel Version 10.2.0: Tue Nov 3 10:37:10 PST 2009; root:xnu-1486.2.11~1/RELEASE_I386 i386
Subject: Re: [rt.cpan.org #57886] installing on SnowLeopard fails run with Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Date: Wed, 26 May 2010 22:46:41 +0200
To: bug-SGML-Parser-OpenSP [...] rt.cpan.org
From: Bjoern Hoehrmann <derhoermi [...] gmx.net>
Download (untitled) / with headers
text/plain 636b
* john via RT wrote: Show quoted text
>Wed May 26 16:37:48 2010: Request 57886 was acted upon. >Transaction: Ticket created by smadness > Queue: SGML-Parser-OpenSP > Subject: installing on SnowLeopard fails run with Symbol not found: > __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
"Fink" appears to have only OpenSP 1.5.1 while, as you will find in the README, the module requires OpenSP 1.5.2. -- Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de 25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/
Subject: Re: [rt.cpan.org #57886] installing on SnowLeopard fails run with Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Date: Wed, 26 May 2010 15:22:36 -0700
To: bug-SGML-Parser-OpenSP [...] rt.cpan.org
From: john gale <john [...] smadness.com>
Download (untitled) / with headers
text/plain 4.4k
On May 26, 2010, at 1:47 PM, Bjoern Hoehrmann via RT wrote: Show quoted text
> * john via RT wrote:
>> Wed May 26 16:37:48 2010: Request 57886 was acted upon. >> Transaction: Ticket created by smadness >> Queue: SGML-Parser-OpenSP >> Subject: installing on SnowLeopard fails run with Symbol not found: >> __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
> > "Fink" appears to have only OpenSP 1.5.1 while, as you will find in the > README, the module requires OpenSP 1.5.2.
Thanks for the reply. From my best estimate it seems that I'm trying to compile against the OpenSP 1.5.2 sources. I've also since switched to MacPorts since it seems to be working better. But the same symbol error occurs, all the output is pasted below. Thanks for the help, ~ john bash-3.2# /mp/bin/port uninstall opensp ---> Deactivating opensp @1.5.2_0 ---> Uninstalling opensp @1.5.2_0 bash-3.2# /mp/bin/port install opensp ---> Computing dependencies for opensp ---> Fetching opensp ---> Verifying checksum(s) for opensp ---> Extracting opensp ---> Configuring opensp ---> Building opensp ---> Staging opensp into destroot ---> Installing opensp @1.5.2_0 ---> Activating opensp @1.5.2_0 ---> Cleaning opensp bash-3.2# grep SP_VERSION /mp/include/OpenSP/config.h #define SP_VERSION "1.5.2" bash-3.2# pwd /Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994 bash-3.2# grep INC Makefile.PL INC => '-I/mp/include', # e.g., '-I/usr/include/other' bash-3.2# make clean bash-3.2# perl Makefile.PL Checking if your kit is complete... Looks good Note (probably harmless): No library found for -lstdc++ Note (probably harmless): No library found for -losp Writing Makefile for SGML::Parser::OpenSP bash-3.2# make cp lib/SGML/Parser/OpenSP.pm blib/lib/SGML/Parser/OpenSP.pm cp lib/SGML/Parser/OpenSP/Tools.pm blib/lib/SGML/Parser/OpenSP/Tools.pm /usr/bin/perl /System/Library/Perl/5.10.0/ExtUtils/xsubpp -C++ -typemap /System/Library/Perl/5.10.0/ExtUtils/typemap -typemap typemap OpenSP.xs > OpenSP.xsc && mv OpenSP.xsc OpenSP.c g++ -c -I/mp/include -arch x86_64 -arch i386 -arch ppc -g -pipe -fno-common -DPERL_DARWIN -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"0.994\" -DXS_VERSION=\"0.994\" "-I/System/Library/Perl/5.10.0/darwin-thread-multi-2level/CORE" -DSP_MULTI_BYTE=1 OpenSP.c OpenSP.c: In function 'void boot_SGML__Parser__OpenSP(PerlInterpreter*, CV*)': OpenSP.c:1363: warning: deprecated conversion from string constant to 'char*' OpenSP.c: In function 'void boot_SGML__Parser__OpenSP(PerlInterpreter*, CV*)': OpenSP.c:1363: warning: deprecated conversion from string constant to 'char*' OpenSP.c: In function 'void boot_SGML__Parser__OpenSP(PerlInterpreter*, CV*)': OpenSP.c:1363: warning: deprecated conversion from string constant to 'char*' Running Mkbootstrap for SGML::Parser::OpenSP () chmod 644 OpenSP.bs rm -f blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle g++ -arch x86_64 -arch i386 -arch ppc -bundle -undefined dynamic_lookup -L/usr/local/lib OpenSP.o -o blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle \ \ chmod 755 blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle cp OpenSP.bs blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bs chmod 644 blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bs Manifying blib/man3/SGML::Parser::OpenSP.3pm Manifying blib/man3/SGML::Parser::OpenSP::Tools.3pm bash-3.2# make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01basic........... # Failed test 'use SGML::Parser::OpenSP;' # at t/01basic.t line 14. t/01basic...........NOK 1/4# Tried to use 'SGML::Parser::OpenSP'. # Error: Can't load '/Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994/blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle' for module SGML::Parser::OpenSP: dlopen(/Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994/blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle, 2): Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE # Referenced from: /Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994/blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle # Expected in: flat namespace # in /Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994/blib/arch/auto/SGML/Parser/OpenSP/OpenSP.bundle at /System/Library/Perl/5.10.0/darwin-thread-multi-2level/DynaLoader.pm line 207. # at (eval 5) line 2 # Compilation failed in require at (eval 5) line 2. # BEGIN failed--compilation aborted at (eval 5) line 2. ...
Subject: Re: [rt.cpan.org #57886] installing on SnowLeopard fails run with Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Date: Thu, 27 May 2010 00:34:25 +0200
To: bug-SGML-Parser-OpenSP [...] rt.cpan.org
From: Bjoern Hoehrmann <derhoermi [...] gmx.net>
Download (untitled) / with headers
text/plain 1.4k
* john via RT wrote: Show quoted text
>bash-3.2# grep SP_VERSION /mp/include/OpenSP/config.h >#define SP_VERSION "1.5.2" > >bash-3.2# pwd >/Users/john/Sites/validator/_downloads/SGML-Parser-OpenSP-0.994 > >bash-3.2# grep INC Makefile.PL > INC => '-I/mp/include', # e.g., '-I/usr/include/other' > >bash-3.2# make clean > >bash-3.2# perl Makefile.PL >Checking if your kit is complete... >Looks good >Note (probably harmless): No library found for -lstdc++ >Note (probably harmless): No library found for -losp >Writing Makefile for SGML::Parser::OpenSP
This probably means you have not set up the library path correctly so it does not find the stdc++ and osp libraries. I note that my assumption you have an outdated OpenSP build was based on your comment that you've to comment out the use of `ParserEventGeneratorKit::showErrorNumbers` which is a "recently" added feature. You might also end up linking to the wrong library, or your library binary is incompatible with your compiler (it might mangle names a bit differently, for instance). First thing I would do is check which library the module is linked against and which symbols the library ex- ports. I am not really the right person to help with this though. -- Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de 25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/
Subject: Re: [rt.cpan.org #57886] installing on SnowLeopard fails run with Symbol not found: __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Date: Thu, 27 May 2010 17:09:19 +0200
To: bug-SGML-Parser-OpenSP [...] rt.cpan.org
From: Bjoern Hoehrmann <derhoermi [...] gmx.net>
Download (untitled) / with headers
text/plain 628b
* john via RT wrote: Show quoted text
>>> Subject: installing on SnowLeopard fails run with Symbol not found: >>> __ZN15SGMLApplication11nonSgmlCharERKNS_16NonSgmlCharEventE
Terje Bless points out that there appear to be pre-built versions of the module available, check out somewhere around here:   http://trac.macports.org/browser/trunk/dports/perl/p5-sgml-parser-opensp/Portfile Maybe you can use that. -- Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de 25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/
(This does not seem to be a problem with SGML::Parser::OpenSP.)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.