This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id:
57326
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
rafl [...] debian.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Tests fail when being run in parallel
Date: Sun, 9 May 2010 22:51:41 +0200
To: bug-Module-Install@rt.cpan.org
From: Florian Ragwitz <rafl@debian.org>
When running the test suite in parallel, i.e. with prove -j2, it starts failing, even tho it passes just fine when run sequentially. The attached log shows how exactly it fails. -- BOFH excuse #224: Jan 9 16:41:27 huber su: 'su root' succeeded for .... on /dev/pts/1

Message body is not shown because sender requested not to inline it.

Message body not shown because it is not plain text.

Sorry for the trouble and thanks for the report. Patched in the trunk. On 2010-5-09 Sun 16:52:00, FLORA wrote:
Show quoted text
> When running the test suite in parallel, i.e. with prove -j2, it starts > failing, even tho it passes just fine when run sequentially. The > attached log shows how exactly it fails. > >
Hi. FYI, Module::Install 0.98 with the fix is out. Thanks. Kenichi On 2010-5-09 Sun 16:52:00, FLORA wrote:
Show quoted text
> When running the test suite in parallel, i.e. with prove -j2, it starts > failing, even tho it passes just fine when run sequentially. The > attached log shows how exactly it fails. > >


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.