Skip Menu |
 

This queue is for tickets about the CPANPLUS CPAN distribution.

Report information
The Basics
Id: 57201
Status: open
Priority: 0/
Queue: CPANPLUS

People
Owner: Nobody in particular
Requestors: TODDR [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.9003
Fixed in: (no value)



Subject: installdirs should be site when > perl 5.11
Download (untitled) / with headers
text/plain 281b
As of 5.12, site_lib comes before the perl core libraries in @INC. All dual life modules should install to site_lib if installed from CPAN. Link to p5p thread on this topic. http://www.xray.mpe.mpg.de/mailing-lists/perl5-porters/2010-04/msg01353.html Patch attached for the fix.
Download (untitled) / with headers
text/plain 612b
diff --git a/Makefile.PL b/Makefile.PL index 69ce11a..1a304d2 100644 --- a/Makefile.PL +++ b/Makefile.PL @@ -176,7 +176,7 @@ could include them into your environment as such (using tcsh): version_from ('lib/CPANPLUS/Internals.pm'); license ('perl'); no_index ( directory => 'lib/CPANPLUS/inc' ); - installdirs ( $] >= 5.009005 ? 'perl' : 'site' ), + installdirs ( $] >= 5.009005 && $] <= 5.011000 ? 'perl' : 'site' ), install_script ($_) for @scripts; #install_script ($_) for grep { $_ !~ /cpanp-boxed/ } glob('bin/*'); requires (%prereq);


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.