Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the ExtUtils-Manifest CPAN distribution.

Report information
The Basics
Id: 57138
Status: rejected
Priority: 0/
Queue: ExtUtils-Manifest

People
Owner: Nobody in particular
Requestors: bitcard [...] krueger-de.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.58
Fixed in: (no value)



Subject: Installing package failed
Download (untitled) / with headers
text/plain 889b
Installing package ... Downloading ExtUtils-Manifest-1.58 ... done Unpacking ExtUtils-Manifest-1.58 ... done Generating HTML for ExtUtils-Manifest-1.58 ... done Updating files in site area ... failed Installing package failed ERROR: File conflict for 'C:/Programme/Perl/html/site/lib/ExtUtils/Manifest.html'. The package ExtUtils-MakeMaker has already installed a file that package ExtUtils-Manifest wants to install. OR Installing package ... Downloading ExtUtils-MakeMaker-6.56 ... done Unpacking ExtUtils-MakeMaker-6.56 ... done Generating HTML for ExtUtils-MakeMaker-6.56 ... done Updating files in site area ... failed Installing package failed ERROR: File conflict for 'C:/Programme/Perl/html/site/lib/ExtUtils/Manifest.html'. The package ExtUtils-Manifest has already installed a file that package ExtUtils-MakeMaker wants to install. And now ??
From: bitcard [...] krueger-de.org
Created also Bug-ID 57139 in ExtUtils-MakeMaker
Download (untitled) / with headers
text/plain 1.2k
It appears you're using some sort of 3rd party Perl module installer. I have no idea what it might be, but you'll have to hunt down its maintainers and take this up with them first. I can tell you this: ERROR: File conflict for 'C:/Programme/Perl/html/site/lib/ExtUtils/Manifest.html'. The package ExtUtils-MakeMaker has already installed a file that package ExtUtils-Manifest wants to install. is true if you do a naive packaging of MakeMaker and your packaging system is inflexible that it will not allow two packages to own the same file. MakeMaker ships with copies of its dependencies, this makes sense if you're doing a source install from CPAN. If you're making a binary package it should remove them from the MakeMaker source, deleting everything in the inc/ directory before building should do it, and have the MakeMaker binary package instead depend on ExtUtils-Manifest, ExtUtils-Install and ExtUtils-Command. With a recent enough Perl, say at least 5.10, MakeMaker can just depend on the Perl package which should ship with everything MakeMaker needs. I don't really keep track of the precise minimum versions of the deps since its simpler to just ship the latest ones. I'm going to call this rejected, but please feel free to continue to correspondence.
Subject: Re: [rt.cpan.org #57138] Installing package failed
Date: Sun, 2 May 2010 18:20:00 +0200
To: <bug-ExtUtils-Manifest [...] rt.cpan.org>
From: <spam [...] andreas-krueger.de>
Download (untitled) / with headers
text/plain 666b
Dear Michael, Michael G Schwern via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=57138 > > > It appears you're using some sort of 3rd party Perl module installer.
I use an ActiveState Perl 5.10 Binarys on Windows. As workaround i installed one of the packages and copy the other .pm manualy. Greting, andreas -- Show quoted text
________________________________________________________________ Persönliche Antworten bitte an a99b00c54@remote.dyndns.info, die Replyadresse wird nicht gelesen ! Mails bitte als Nur Text Senden !! Send Private-Messages only to a99b00c54@remote.dyndns.info, the reply adress will not be read ! Please send only as Plaintext !!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.