Skip Menu |
 

This queue is for tickets about the Encode-HanExtra CPAN distribution.

Report information
The Basics
Id: 57042
Status: open
Priority: 0/
Queue: Encode-HanExtra

People
Owner: Nobody in particular
Requestors: mb [...] otrs.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Encode::HanExtra is not building on StrawberryPerl because of Makefile issues
Download (untitled) / with headers
text/plain 432b
Hi, If I'm building Encode::HanExtra on StrawberryPerl 5.12 April 2010 32-bit, it fails. On earlier versions, it worked OK. BinGOs from the #win32 IRC channel mentioned: "it is Encode::HanExtra's problem. It is doing a scan for enc2xs file existing. it should actually be trying to run enc2xs. Module::Install actually has a function for this: can_run('enc2xs')" Can you please look into fixing the Makefile.PL? Regards, Mike.
Download (untitled) / with headers
text/plain 1.2k
On Thu Apr 29 10:57:27 2010, https://launchpad.net/~michiel-beijen wrote: Show quoted text
> Hi, > > If I'm building Encode::HanExtra on StrawberryPerl 5.12 April 2010 > 32-bit, it fails. On earlier versions, it worked OK. > > BinGOs from the #win32 IRC channel mentioned: > > "it is Encode::HanExtra's problem. It is doing a scan for enc2xs file > existing. it should actually be trying to run enc2xs. Module::Install > actually has a function for this: can_run('enc2xs')" > > Can you please look into fixing the Makefile.PL? > > Regards, > > Mike.
For your information: This is the second bug I've ran into since the April release where a module expects scripts installed with perl to be executable from the command prompt without an extension, which *isn't the case* on non-Unix systems. (I'm not blaming you for the first, just stating facts) Perl's 'make install' itself does not copy the scripts once it creates the .bat file from them on Windows, and this is what makes the problem appear. I'm also told that copying both the batch file and the script will be removed from EU::MM as well, eventually, so working around it by forcing the installation of Encode will not cause the problem to disappear, like it would now... Better to solve this some other way. I'll try and get back to you with a possible fix.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.