Skip Menu |
 

This queue is for tickets about the Dancer-Plugin-SiteMap-withoutworldwriteables CPAN distribution.

Report information
The Basics
Id: 56710
Status: resolved
Priority: 0/
Queue: Dancer-Plugin-SiteMap-withoutworldwriteables

People
Owner: Nobody in particular
Requestors: james2vegas [...] aim.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: Unnecessary 5.10 requirement
In lib/Dancer/Plugin/SiteMap.pm, the line 'use 5.0100;' preventing installation of this module on any version less than 5.10, but it there doesn't seem to be any code that requires that restriction.  After removing that line, here are the results (this is perl 5.8.9 on freebsd-i386):

Show quoted text
# perl Makefile.PL
Writing Makefile for Dancer::Plugin::SiteMap
Show quoted text
# make
Skip blib/lib/Dancer/Plugin/SiteMap.pm (unchanged)
Skip blib/lib/Dancer/Plugin/logs/development.log (unchanged)
Manifying blib/man3/Dancer::Plugin::SiteMap.3
Show quoted text
# make test
# perl -c blib/lib/Dancer/Plugin/SiteMap.pm
blib/lib/Dancer/Plugin/SiteMap.pm syntax OK

and installing the module and using it in an existing Dancer app (created using dancer -a), the /sitemap and /sitemap.xml links work as expected.

Obviously it is your prerogative to limit your module's use to Perl versions 5.10 and later, but why not enable 5.8 users (at least) to use your module too, especially considering that Dancer's Perl version requirements are much lower.
Download (untitled) / with headers
text/plain 191b
I removed the 5.10 requirement a while back and obviously never closed this bug. FYI: There's a new release going up on CPAN shortly with a fix for a clash with the newer template engines.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.