Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 56460
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: florent.angly [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.95
Fixed in: (no value)



Subject: Bundle documentation error?
Download (untitled) / with headers
text/plain 296b
The documentation for Module::Install::Bundle states that it is required to add a line such as requires( perl => 5.005 ); to use the bundle_deps() and auto_bundle_deps() methods. When I do so, I get an error. In fact it seems like it is not necessary to require a specific version of Perl.
Subject: Makefile_test_3.PL
Download Makefile_test_3.PL
text/x-perl 317b
use inc::Module::Install; name 'GAAS'; all_from 'lib/GAAS.pm'; build_requires 'Test::More'; print "Requiring a specific Perl version, as the documentation says to do\n"; requires( perl => 5.005 ); print "Requiring a module that contains several *.pm files\n"; requires 'Error'; auto_bundle_deps; WriteAll;
Subject: log3.txt
Download log3.txt
text/plain 426b
$ perl Makefile_test_3.PL include /home/floflooo/Work/GAAS/program/GAAS/inc/Module/Install.pm include inc/Module/Install/Metadata.pm include inc/Module/Install/Base.pm Requiring a specific Perl version, as the documentation says to do Requiring a module that contains several *.pm files include inc/Module/Install/Bundle.pm Cannot find bundle source for perl at /usr/local/share/perl/5.10.1/Module/Install/Bundle.pm line 38.
Download (untitled) / with headers
text/plain 487b
Hi. Fixed the doc in the trunk. You should use perl_version('5.005') (or perl_version_from('lib/Foo/Bar.pm') instead FYI. Thanks. On 2010-4-10 Sat 07:58:45, FANGLY wrote: Show quoted text
> The documentation for Module::Install::Bundle states that it is
required Show quoted text
> to add a line such as > requires( perl => 5.005 ); > to use the bundle_deps() and auto_bundle_deps() methods. > > When I do so, I get an error. In fact it seems like it is not
necessary Show quoted text
> to require a specific version of Perl.
Hi. Closed this ticket as fixed too. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.