Skip Menu |
 

This queue is for tickets about the Crypt-OpenSSL-RSA CPAN distribution.

Report information
The Basics
Id: 56454
Status: resolved
Priority: 0/
Queue: Crypt-OpenSSL-RSA

People
Owner: Nobody in particular
Requestors: kmx [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Win32 compatibility patch
Hi,

Please consider aplying the following simple patch to Makefile.PL that enables building this module on Win32 Strawberry Perl

diff -ru Crypt-OpenSSL-RSA-0.26.orig\Makefile.PL Crypt-OpenSSL-RSA-0.26\Makefile.PL
--- Crypt-OpenSSL-RSA-0.26.orig\Makefile.PL    Tue Nov 15 05:08:38 2005
+++ Crypt-OpenSSL-RSA-0.26\Makefile.PL    Sat Apr 10 08:50:04 2010
@@ -11,7 +11,7 @@
     'DISTNAME' => 'Crypt-OpenSSL-RSA',
     'VERSION_FROM' => 'RSA.pm', # finds $VERSION
     'OBJECT' => 'RSA.o',
-    'LIBS'    => ['-lssl -lcrypto'],   # e.g., '-lm'
+    'LIBS'    => ($^O eq 'MSWin32') ? ['-lssl32 -leay32'] : ['-lssl -lcrypto'],
     'PREREQ_PM' => { 'Crypt::OpenSSL::Random' => 0 },
     'DEFINE'    => '-DPERL5 -DOPENSSL_NO_KRB5',
     # perl-5.8/gcc-3.2 needs -DPERL5, and redhat9 likes -DOPENSSL_NO_KRB5

--
kmx
From: mpapet [...] yahoo.com
Download (untitled) / with headers
text/plain 905b
On Sat Apr 10 03:15:41 2010, KMX wrote: Show quoted text
> Hi, > > Please consider aplying the following simple patch to Makefile.PL that > enables > building this module on Win32 Strawberry Perl > > diff -ru Crypt-OpenSSL-RSA-0.26.orig\Makefile.PL > Crypt-OpenSSL-RSA-0.26\Makefile.PL > --- Crypt-OpenSSL-RSA-0.26.orig\Makefile.PL Tue Nov 15 05:08:38 2005 > +++ Crypt-OpenSSL-RSA-0.26\Makefile.PL Sat Apr 10 08:50:04 2010 > @@ -11,7 +11,7 @@ > 'DISTNAME' => 'Crypt-OpenSSL-RSA', > 'VERSION_FROM' => 'RSA.pm', # finds $VERSION > 'OBJECT' => 'RSA.o', > - 'LIBS' => ['-lssl -lcrypto'], # e.g., '-lm' > + 'LIBS' => ($^O eq 'MSWin32') ? ['-lssl32 -leay32'] : ['-lssl > -lcrypto'], > 'PREREQ_PM' => { 'Crypt::OpenSSL::Random' => 0 }, > 'DEFINE' => '-DPERL5 -DOPENSSL_NO_KRB5', > # perl-5.8/gcc-3.2 needs -DPERL5, and redhat9 likes -DOPENSSL_NO_KRB5 > > -- > kmx
This patch works for me on Strawberry Perl. I recommend it.
Hi,

can I help somehow with fixing this issue?

If you give me co-maint (my id is KMX) and point me to your repository with the latest sources I can volunteer and release fixed version.

--
kmx

Download (untitled) / with headers
text/plain 381b
The patch has been included in the latest release. Thank you very much! https://metacpan.org/release/Crypt-OpenSSL-RSA Am Fr 10. Jun 2011, 03:26:53, KMX schrieb: Show quoted text
> Hi, > > can I help somehow with fixing this issue? > > If you give me co-maint (my id is KMX) and point me to your repository > with the > latest sources I can volunteer and release fixed version. > > -- > kmx


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.