Skip Menu |
 

This queue is for tickets about the DBD-Pg CPAN distribution.

Report information
The Basics
Id: 56363
Status: resolved
Priority: 0/
Queue: DBD-Pg

People
Owner: greg [...] turnstep.com
Requestors: chris [...] computersalat.de
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: (no value)
Fixed in: 2.17.1



Subject: testsuite fails for postgres < 8.4
Download (untitled) / with headers
text/plain 834b
Hi, test fails due to "undefined symbol: lo_import_with_oid" and due compile, there is a warning: dbdimp.c: In function 'pg_db_lo_import_with_oid': dbdimp.c:4433: warning: implicit declaration of function 'lo_import_with_oid' t/00basic........... # Failed test 'use DBD::Pg;' # at t/00basic.t line 14. # Tried to use 'DBD::Pg'. # Error: Can't load '/usr/src/packages/BUILD/DBD-Pg-2.17.0/blib/arch/auto/DBD/Pg/Pg.so' for module DBD::Pg: /usr/sr c/packages/BUILD/DBD-Pg-2.17.0/blib/arch/auto/DBD/Pg/Pg.so: undefined symbol: lo_import_with_oid at /usr/lib/perl5/5.10. 0/x86_64-linux-thread-multi/DynaLoader.pm line 203. obs:/usr/lib64> rpm -qa | grep postgr postgresql-libs-8.3.5-2.15 postgresql-devel-8.3.5-2.15 with postgres >= 8.4 it builds just fine so minum required postgres >= 8.4 and not 7.4 Kind Regards Chris
Download (untitled) / with headers
text/plain 125b
Thanks for the report. Make a quick fix in r13895 : please test if you are able. http://svn.perl.org/modules/DBD-Pg/trunk/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.