Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 56348
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: marcel [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.100960
Fixed in: (no value)



Subject: Requires App::Cmd 0.307
Download (untitled) / with headers
text/plain 804b
I had App::Cmd 0.301 and got while running tests: # Failed test 'require Dist::Zilla::App;' # at t/compile.t line 17. # Tried to require 'Dist::Zilla::App'. # Error: App::Cmd::Setup does not define $App::Cmd::Setup::VERSION--version check failed at /home/samba/gr/.cpanm/work/1270650641.24154/Dist-Zilla- 2.100960/blib/lib/Dist/Zilla/App.pm line 8. # BEGIN failed--compilation aborted at /home/samba/gr/.cpanm/work/1270650641.24154/Dist-Zilla- 2.100960/blib/lib/Dist/Zilla/App.pm line 8. # Compilation failed in require at (eval 331) line 2. Version string '-1, set by base.pm' contains invalid data; ignoring: '-1, set by base.pm' at /home/samba/gr/.cpanm/work/1270650641.24154/Dist-Zilla- 2.100960/blib/lib/Dist/Zilla/App/Tester.pm line 6. After upgrading to App::Cmd 0.307 it worked.
has since been fixed -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.