Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 55995
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: dagolden [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: Increase minimum EU::MM and protect additional args depending on version
Download (untitled) / with headers
text/plain 335b
Dist::Zilla should require a minimum EU::MM of 6.31, which is when INSTALL_BASE was added. LICENSE was also available in 6.31, so it no longer would need to be deleted from args. However, the following need to be deleted depending on EU::MM version: CONFIGURE_REQUIRES (added in 6.52) BUILD_REQUIRES (added in 6.56) -- David
Subject: Re: [rt.cpan.org #55995] Increase minimum EU::MM and protect additional args depending on version
Date: Sat, 27 Mar 2010 08:01:08 -0400
To: David Golden via RT <bug-Dist-Zilla [...] rt.cpan.org>
From: Ricardo Signes <rjbs [...] cpan.org>
Download (untitled) / with headers
text/plain 391b
* David Golden via RT <bug-Dist-Zilla@rt.cpan.org> [2010-03-27T07:36:03] Show quoted text
> Dist::Zilla should require a minimum EU::MM of 6.31, which is when > INSTALL_BASE was added.
Thanks, I'll do that. Show quoted text
> However, the following need to be deleted depending on EU::MM version: > > CONFIGURE_REQUIRES (added in 6.52) > BUILD_REQUIRES (added in 6.56)
That's done in git master already. :) -- rjbs
fixed in git -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.