Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 55974
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: frankie [...] etsetb.upc.edu
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.95
Fixed in: (no value)



Subject: FakeAdmin does not define
Download (untitled) / with headers
text/plain 528b
Hi, this is a Debian etch with a source build perl v5.8.8. When trying to install Module::Install, it won't create the Makefile. perl Makefile.PL Module::Install::Base::FakeAdmin does not define $Module::Install::Base::FakeAdmin::VERSION--version check failed at /usr/local/web21/perl/lib/site_perl/5.8.8/version/vpp.pm line 402. I fixed it adding to the source of inc/Module/Install/Base.pm, line 61: package Module::Install::Base::FakeAdmin; use vars qw{$VERSION}; BEGIN { $VERSION = '0.95'; }
Download (untitled) / with headers
text/plain 779b
Hmm. I couldn't reproduce the issue. With which version of Module::Install and version.pm, and how (from CPAN, from downloaded tarball, etc) did you try to install? On 2010-3-26 Fri 10:38:06, FRANKIE wrote: Show quoted text
> Hi, this is a Debian etch with a source build perl v5.8.8. When trying > to install Module::Install, it won't create the Makefile. > > > perl Makefile.PL > Module::Install::Base::FakeAdmin does not define > $Module::Install::Base::FakeAdmin::VERSION--version check failed at > /usr/local/web21/perl/lib/site_perl/5.8.8/version/vpp.pm line 402. > > I fixed it adding to the source of inc/Module/Install/Base.pm, line
61: Show quoted text
> > package Module::Install::Base::FakeAdmin; > > use vars qw{$VERSION}; > BEGIN { > $VERSION = '0.95'; > } > >
Subject: Re: [rt.cpan.org #55974] FakeAdmin does not define
Date: Thu, 8 Apr 2010 10:01:57 +0200
To: Kenichi Ishigaki via RT <bug-Module-Install [...] rt.cpan.org>
From: Francesc Guasch <frankie [...] etsetb.upc.edu>
Download (untitled) / with headers
text/plain 1021b
On Fri, Apr 02, 2010 at 09:23:04AM -0400, Kenichi Ishigaki via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=55974 > > > Hmm. I couldn't reproduce the issue. With which version of > Module::Install and version.pm, and how (from CPAN, from downloaded > tarball, etc) did you try to install?
Sorry, I downloaded Module-Install 0.95. This was a really old installation. I had serious issues trying to update cpan modules in this host. All with modules using Module::Install. They complained like this: Module::Install::Base::FakeAdmin does not define $Module::Install::Base::FakeAdmin::VERSION--version check failed at /usr/local/web21/perl/lib/site_perl/5.8.8/version/vpp.pm line 402. Finally I ended up installing Module-Install-0.54.tar.gz, then I was able to install the latest modules. I know it is hard to reproduce. Having it fixed in my host I am not able to reproduce it myself. Anyway I think adding $VERSION = 0.95; to package Module::Install::Base::FakeAdmin; won't do any harm.
Download (untitled) / with headers
text/plain 1.1k
OK. Added $VERSION to ::FakeAdmin in the trunk. Will be fixed in the next release. Thanks. On 2010-4-08 Thu 04:02:39, FRANKIE wrote: Show quoted text
> On Fri, Apr 02, 2010 at 09:23:04AM -0400, Kenichi Ishigaki via RT
wrote: Show quoted text
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=55974 > > > > > Hmm. I couldn't reproduce the issue. With which version of > > Module::Install and version.pm, and how (from CPAN, from downloaded > > tarball, etc) did you try to install?
> > Sorry, I downloaded Module-Install 0.95. > > This was a really old installation. I had serious issues trying > to update cpan modules in this host. All with modules using > Module::Install. They complained like this: > > Module::Install::Base::FakeAdmin does not define > > $Module::Install::Base::FakeAdmin::VERSION--version check failed at > /usr/local/web21/perl/lib/site_perl/5.8.8/version/vpp.pm line 402. > > Finally I ended up installing Module-Install-0.54.tar.gz, then I was > able to install the latest modules. > > I know it is hard to reproduce. Having it fixed in my host I am not > able to reproduce it myself. Anyway I think adding $VERSION = 0.95; > to package Module::Install::Base::FakeAdmin; won't do any harm. >
Hi. Module::Install 0.96/0.97 with a fix is out. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.