Skip Menu |
 

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id: 55924
Status: resolved
Priority: 0/
Queue: Perl-Dist-Strawberry

People
Owner: Nobody in particular
Requestors: kmx [...] volny.cz
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Re: CPAN dir moving - random failures
Date: Thu, 25 Mar 2010 10:01:44 +0100
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: kmx <kmx [...] volny.cz>
Download (untitled) / with headers
text/plain 1.6k
Just for record sending this to Strawberry's RT - I know that it is not a problem of Strawberry itself; however it casts a "bad light" on Strawberry as users simply see that cpan installation in certain cases fails. We should perhaps investigate & find a workaround (after April release) - AFAIK some guy was also asking about that on win32-perl list (and bunch of others not asking are definitely suffering also). -- kmx Dne 10.3.2010 12:23, Curtis Jewell napsal(a): Show quoted text
> Yes, thanks! (Microsoft Security Essentials) > > This had been frustrating me for 2 days now, and it would usually happen > with GD or Imager (right near the end, in other words!) > > --Curtis > > On Wed, 10 Mar 2010 09:37 +0100, "kmx" <kmx@volny.cz> wrote: >
>> Dne 9.3.2010 21:34, Curtis Jewell napsal(a): >>
>>> 64-bit Perl builds fine, when CPAN is wanting to move directories around >>> (it's acting like it's Schrodinger's cat, and randomly not moving its >>> temp directories inside cpan/build maybe .75% of the time.) - it's just >>> that this is needed for creating the .msi. >>> >>>
>> I have also experienced similar issues - my theory is that it is due to >> the antivirus SW >> - cpan clients unpacks a bunch of data >> - immediately after that cpan clients tries to move the whole upacked >> dir somewhere else >> - however AV has kind of a lock on the original directory as it did not >> finish the scanning of new files before "move dir" was called >> - from the outside it simply seems like "move failed" >> >> Do you have any AV running? If yes, could you try to disable it? >> >> -- >> kmx
> -- > Curtis Jewell > swordsman@csjewell.fastmail.us
Download (untitled) / with headers
text/plain 1.8k
First thing to do is to release-note this... I'll do that once I finish the 64-bit build of 5.12.0-RC0 Beta 1. On Thu Mar 25 05:01:59 2010, kmx@volny.cz wrote: Show quoted text
> Just for record sending this to Strawberry's RT - I know that it is not > a problem of Strawberry itself; however it casts a "bad light" on > Strawberry as users simply see that cpan installation in certain cases > fails. > > We should perhaps investigate & find a workaround (after April release) > - AFAIK some guy was also asking about that on win32-perl list (and > bunch of others not asking are definitely suffering also). > > -- > kmx > > > Dne 10.3.2010 12:23, Curtis Jewell napsal(a):
> > Yes, thanks! (Microsoft Security Essentials) > > > > This had been frustrating me for 2 days now, and it would usually happen > > with GD or Imager (right near the end, in other words!) > > > > --Curtis > > > > On Wed, 10 Mar 2010 09:37 +0100, "kmx" <kmx@volny.cz> wrote: > >
> >> Dne 9.3.2010 21:34, Curtis Jewell napsal(a): > >>
> >>> 64-bit Perl builds fine, when CPAN is wanting to move directories
around Show quoted text
> >>> (it's acting like it's Schrodinger's cat, and randomly not moving its > >>> temp directories inside cpan/build maybe .75% of the time.) - it's
just Show quoted text
> >>> that this is needed for creating the .msi. > >>> > >>>
> >> I have also experienced similar issues - my theory is that it is due to > >> the antivirus SW > >> - cpan clients unpacks a bunch of data > >> - immediately after that cpan clients tries to move the whole upacked > >> dir somewhere else > >> - however AV has kind of a lock on the original directory as it
did not Show quoted text
> >> finish the scanning of new files before "move dir" was called > >> - from the outside it simply seems like "move failed" > >> > >> Do you have any AV running? If yes, could you try to disable it? > >> > >> -- > >> kmx
> > -- > > Curtis Jewell > > swordsman@csjewell.fastmail.us
>
Release-noted in r11757.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.