This queue is for tickets about the CHI CPAN distribution.

Report information
The Basics
Id:
55920
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
RSAVAGE [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.34
Fixed in:
(no value)



Subject: Cache::FastMmap not listed as requirement in META.yml
Hi Folks Firstly, Cache::FastMmap is not listed as a requirement (for CHI::Driver::FastMMap) in META.yml. This means cpanm does not install Cache::FastMmap. Secondly, that module, and perhaps others, does not have something like: our $VERSION = '0.34'; at the top. Cheers Ron
The intention was not to require Cache::FastMmap for CHI, but to have it be an optional requirement only if that driver were used. CHI::Driver::FastMmap should probably be in its own distro in the long run, like CHI::Driver::Memcached. For now I've added this to the docs for CHI::Driver::FastMmap: =head1 REQUIREMENTS You will need to install L<Cache::FastMmap|Cache::FastMmap> from CPAN to use this driver. On Wed Mar 24 21:22:38 2010, RSAVAGE wrote:
Show quoted text
> Hi Folks > > Firstly, Cache::FastMmap is not listed as a requirement (for > CHI::Driver::FastMMap) in META.yml. > This means cpanm does not install Cache::FastMmap. > > Secondly, that module, and perhaps others, does not have something like: > our $VERSION = '0.34'; > at the top. > > Cheers > Ron
Subject: Re: [rt.cpan.org #55920] Cache::FastMmap not listed as requirement in META.yml
Date: Tue, 11 May 2010 10:06:06 +1000
To: bug-CHI@rt.cpan.org
From: Ron Savage <ron@savage.net.au>
Hi Jonathan On Mon, 2010-05-10 at 19:34 -0400, Jonathan Swartz via RT wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=55920 > > > The intention was not to require Cache::FastMmap for CHI, but to have it > be an optional requirement only if that driver were used. > > CHI::Driver::FastMmap should probably be in its own distro in the long > run, like CHI::Driver::Memcached. > > For now I've added this to the docs for CHI::Driver::FastMmap: > > =head1 REQUIREMENTS > > You will need to install L<Cache::FastMmap|Cache::FastMmap> from CPAN > to use this driver.
OK. Thanx. -- Ron Savage http://savage.net.au/ 0421 920 622


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.