Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 55576
Status: stalled
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: APOCAL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: Add detection for my $x->{a} = $a; syntax added in 5.10.0
Download (untitled) / with headers
text/plain 667b
Hello, While tracking down a bug in Metabase::Fact I came across this syntax. After some investigation it turned out to be an undocumented addition to 5.10.0. I've filed a perlbug report for it, as seen here: http://rt.perl.org/rt3//Public/Bug/Display.html?id=73570 I'm not a PPI guru, sorry! I assume it would be possible to add detection for this syntax and note a minimum version of 5.10.0? Thanks again for your work on this excellent module! apoc@blackhole:~$ cat testminv.pl use strict; use warnings; use Perl::MinimumVersion; print Perl::MinimumVersion->new(\'my $x->{a} = "a"')->minimum_version; apoc@blackhole:~$ perl testminv.pl 5.004 -- ~Apocalypse


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.