Skip Menu |
 

This queue is for tickets about the XML-RSS CPAN distribution.

Report information
The Basics
Id: 5547
Status: resolved
Priority: 0/
Queue: XML-RSS

People
Owner: KELLAN [...] cpan.org
Requestors: support [...] siwan.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.02
Fixed in: (no value)



Subject: encoding on german umlaut does not work
Download (untitled) / with headers
text/plain 1.2k
I'm using the rss2html tool by Jonathan Eisenzopf as a simple test if XML::RSS is something for our case. Ifound it very easy to use. Unfortunatly does the encoding for is0-8859-1 not work. As you may know do we have some special characters here in Germany. Try to use http://www.netzeitung.de/export/news/rss/titelseite.xml and you will see strang characters. I spend a whole day on figuring out what could be wrong. It seems that the modul does not recognize the encoding type from the document. It is useful to extent the new command like my $rss = new XML::RSS (encoding =>'ISO-8859-1'); Now you see in the as_string outpu that the enconding in the XML line is correct but still the characters a strang. So I think the parser does not encode at all. I installed the XML::RSS package via CPAN and XML::Parser and XML::Parser::Expat are lso installed via CPAN. One thing makes me wonder. I get the warning Use of uninitialized value in exists at /usr/lib/perl5/site_perl/5.6.0/XML/RSS.pm line 1434 but couldn't realy figure out, why $el is not defined. Please respond as soon as possible, because I am in a project where I would love to use that stuff. Even a workaround woul be fine. Thankx in advance. Regards Guido Schüller, http://www.siwan.de
From: ABH [...] cpan.org
Download (untitled) / with headers
text/plain 1.4k
On Wed Mar 03 13:38:03 2004, guest wrote: Show quoted text
> I'm using the rss2html tool by Jonathan Eisenzopf as a simple test if > XML::RSS is something for our case. Ifound it very easy to use. > Unfortunatly does the encoding for is0-8859-1 not work. As you may > know do we have some special characters here in Germany. Try to use > http://www.netzeitung.de/export/news/rss/titelseite.xml and you > will see strang characters. > > I spend a whole day on figuring out what could be wrong. It seems that > the modul does not recognize the encoding type from the document. > It is useful to extent the new command like > > my $rss = new XML::RSS (encoding =>'ISO-8859-1'); > > Now you see in the as_string outpu that the enconding in the XML line > is correct but still the characters a strang. > > So I think the parser does not encode at all. I installed the XML::RSS > package via CPAN and XML::Parser and XML::Parser::Expat are lso > installed via CPAN. > > One thing makes me wonder. I get the warning > > Use of uninitialized value in exists at > /usr/lib/perl5/site_perl/5.6.0/XML/RSS.pm line 1434 > > but couldn't realy figure out, why $el is not defined. > > Please respond as soon as possible, because I am in a project where I > would love to use that stuff. Even a workaround woul be fine.
Without seeing an example I don't entirely understand what the issue is -- however, I suspect it's been fixed in recent releases. If not, can you provide an example we can use for a test?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.