This queue is for tickets about the Algorithm-Evolutionary CPAN distribution.

Report information
The Basics
Id:
54998
Status:
resolved
Worked:
30 minutes
Users:
JMERELO: 30 minutes
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
jquelin [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
0.72
Fixed in:
(no value)



Subject: Algorithm::Evolutionary::Op::CanonicalGA version mismatch
latest Algorithm-Evolutionary (0.72) is bundling Algorithm::Evolutionary::Op::CanonicalGA-3.004 however, version 0.71 was shipping Algorithm::Evolutionary::Op::CanonicalGA-3.1 perl, cpan and cpanplus handle versions as numbers. in that case: 3.1 == 3.100 > 3.004 ==> therefore, cpanplus wants to downgrade algorithm-evolutionary: $ cpanp o 1 3.004 3.10 Algorithm::Evolutionary::Op::CanonicalGA JMERELO ... what to do to fix that? release a new version of your dist, but this time making sure that Algorithm::Evolutionary::Op::CanonicalGA has a version strictly greater than 3.1 this version can be: 3.200, 3.2 (same as 3.200), 3.101, 3.100.1, 4.000, etc. i have not checked the other modules shipped by the dist, but they may have the same problem too. one way to be sure that the problem never comes again is to assign the same version number to all your modules within a same dist. but this would mean bumping version to at least 3.2 for all your modules.
El Jue feb 25 14:05:09 2010, JQUELIN escribió:
Show quoted text
> latest Algorithm-Evolutionary (0.72) is bundling > Algorithm::Evolutionary::Op::CanonicalGA-3.004 > > however, version 0.71 was shipping > Algorithm::Evolutionary::Op::CanonicalGA-3.1 > > > perl, cpan and cpanplus handle versions as numbers. in that case: > 3.1 == 3.100 > 3.004 > > ==> therefore, cpanplus wants to downgrade algorithm-evolutionary: > $ cpanp o > 1 3.004 3.10 Algorithm::Evolutionary::Op::CanonicalGA > JMERELO > ... > > what to do to fix that? release a new version of your dist, but this > time making sure that Algorithm::Evolutionary::Op::CanonicalGA has a > version strictly greater than 3.1 > this version can be: 3.200, 3.2 (same as 3.200), 3.101, 3.100.1,
4.000, etc.
Show quoted text
> > i have not checked the other modules shipped by the dist, but they may > have the same problem too. one way to be sure that the problem never > comes again is to assign the same version number to all your modules > within a same dist. but this would mean bumping version to at least 3.2 > for all your modules. >
Yep, I noticed that when I got the indexing report. Will try to fix it in the next release, but I don't plan to do it soon ( == in the next week or so). Thanks anyways for the report. JJ
Fixed in recently uploaded version 0.73 . Thanks for the report. JJ


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.