This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id:
54890
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
miyagawa [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: MYMETA.yml creation doesn't work
Date: Mon, 22 Feb 2010 12:50:21 -0800
To: bug-Module-Install@rt.cpan.org
From: Tatsuhiko Miyagawa <miyagawa@gmail.com>
http://cpansearch.perl.org/src/XSAWYERX/Task-Dancer-0.06/Makefile.PL env PERL5_CPAN_IS_RUNNING=1 X_MYMETA=YAML perl Makefile.PL and hit some 'y' for questions and look at the MYMETA.yml file: it doesn't have 'requires' for the modules you hit 'y' for. This means the generated MYMETA.yml is completely useless. -- Tatsuhiko Miyagawa
Fixed in the trunk. Thanks. On 2010-2-22 Mon 16:07:39, miyagawa@gmail.com wrote:
Show quoted text
> http://cpansearch.perl.org/src/XSAWYERX/Task-Dancer-0.06/Makefile.PL > env PERL5_CPAN_IS_RUNNING=1 X_MYMETA=YAML perl Makefile.PL > > and hit some 'y' for questions and look at the MYMETA.yml file: it > doesn't have 'requires' for the modules you hit 'y' for. This means > the generated MYMETA.yml is completely useless. >
Hi. Module::Install 0.96/0.97 with a fix is out. Thanks.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.