Skip Menu |
 
Update: The rt.cpan.org bug tracker service is no longer shutting down.

This queue is for tickets about the IO-Prompt CPAN distribution.

Report information
The Basics
Id: 54807
Status: open
Priority: 0/
Queue: IO-Prompt

People
Owner: Nobody in particular
Requestors: salvatore.bonaccorso [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.997
Fixed in: (no value)



Subject: IO-Prompt fails to build in environments without /dev/tty
Download (untitled) / with headers
text/plain 1.2k
Hi In Debian we have on buildd with sbuild no /dev/tty in the build-environment. Trying to build IO-Prompt in such an environment, fails the tests: # Failed test 'Output to /dev/tty' # at t/01.dependencies.t line 4. # Failed test 'Input from /dev/tty' # at t/01.dependencies.t line 5. # Looks like you failed 2 tests of 2. t/01.dependencies.t .. Trying to experiment with IO:Pty and adding the following patch: ---(patch)--------------------------------------------- +--- a/t/01.dependencies.t ++++ b/t/01.dependencies.t +@@ -1,5 +1,8 @@ + use Test::More tests => 2; ++use IO::Pty; + +-# Depends on hardcoded /dev/tty access +-ok( open(my $OUT, ">/dev/tty"), "Output to /dev/tty"); +-ok( open(my $IN, "</dev/tty"), "Input from /dev/tty"); ++$pty = new IO::Pty; ++$tty = $pty->ttyname(); ++ ++ok( open(my $OUT, ">$tty"), "Output to $tty"); ++ok( open(my $IN, "<$tty"), "Input from $tty"); ------------------------------------------------------- now IO-Prompt builds, however there is still: t/01.dependencies.t .. ok Too late to run CHECK block at /build/salvi-libio-prompt-perl_0.997-1-amd64-YbnibD/libio-prompt-perl-0.997-1/blib/lib/IO/Prompt.pm line 319. many thanks in advance considering looking into this, Bests Salvatore
From: ppisar [...] redhat.com
Download (untitled) / with headers
text/plain 266b
Dne Pá 19.úno.2010 15:01:45, https://launchpad.net/~carnil napsal(a): Show quoted text
> In Debian we have on buildd with sbuild no /dev/tty in the > build-environment. Trying to build IO-Prompt in such an environment,
Was this very same issue fixed in 0.997003 as CPAN RT#106521?
Subject: Re: [rt.cpan.org #54807] IO-Prompt fails to build in environments without /dev/tty
Date: Wed, 26 Aug 2015 17:42:54 +1000
To: bug-IO-Prompt [...] rt.cpan.org
From: Damian Conway <damian [...] conway.org>
Download (untitled) / with headers
text/plain 121b
Show quoted text
> Was this very same issue fixed in 0.997003 as CPAN RT#106521?
Yes, it was. Thanks for noting the duplication. Damian


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.