Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 54170
Status: open
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: sprout [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Prerequisites are processed in the wrong order
Date: Sun, 31 Jan 2010 12:52:16 -0800
To: bug-CPAN [...] rt.cpan.org
From: Father Chrysostomos <sprout [...] cpan.org>
Download (untitled) / with headers
text/plain 351b
Please see the report at <https://rt.cpan.org/Ticket/Display.html?id=53898 Show quoted text
>. The transcript (<https://rt.cpan.org/Ticket/Attachment/723249/373464/error >) shows that HTML::DOM is processed before its prerequisites. I
cannot reproduce this myself. This is with CPAN 1.9402. Is this a known issue? Has it been fixed in the latest dev release?
Subject: Re: [rt.cpan.org #54170] Prerequisites are processed in the wrong order
Date: Sun, 31 Jan 2010 19:46:18 -0500
To: bug-CPAN [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 824b
On Sun, Jan 31, 2010 at 3:53 PM, Father Chrysostomos via RT <bug-CPAN@rt.cpan.org> wrote: Show quoted text
> Please see the report at <https://rt.cpan.org/Ticket/Display.html?id=53898 >  >. The transcript (<https://rt.cpan.org/Ticket/Attachment/723249/373464/error >  >) shows that HTML::DOM is processed before its prerequisites. I > cannot reproduce this myself. This is with CPAN 1.9402. Is this a > known issue? Has it been fixed in the latest dev release?
I was also unable to replicate this error, either on CPAN 1.9402 or on the latest version in the repository. There have been a number of heisenbugs involving prerequisite resolution and the repository has some recent changes that attempt to fix them despite the lack of a clear diagnosis. Without replication, there's no way to know if the problem has been fixed. -- David
Download (untitled) / with headers
text/plain 999b
On Sun Jan 31 19:47:35 2010, DAGOLDEN wrote: Show quoted text
> On Sun, Jan 31, 2010 at 3:53 PM, Father Chrysostomos via RT > <bug-CPAN@rt.cpan.org> wrote:
> > Please see the report at
> <https://rt.cpan.org/Ticket/Display.html?id=53898
> >  >. The transcript
> (<https://rt.cpan.org/Ticket/Attachment/723249/373464/error
> >  >) shows that HTML::DOM is processed before its prerequisites. I > > cannot reproduce this myself. This is with CPAN 1.9402. Is this a > > known issue? Has it been fixed in the latest dev release?
> > I was also unable to replicate this error, either on CPAN 1.9402 or > on the latest version in the repository. > > There have been a number of heisenbugs involving prerequisite > resolution and the repository has some recent changes that attempt to > fix them despite the lack of a clear diagnosis. > > Without replication, there's no way to know if the problem has been > fixed.
I managed to replicate this with ‘test Jifty::DBI’. I can no longer reproduce it as of 1.94_55.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.