This queue is for tickets about the Catalyst-Controller-HTML-FormFu CPAN distribution.

Report information
The Basics
Id:
54118
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
sven [...] sveneppler.de
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Documentation lacks updates
Date: Fri, 29 Jan 2010 15:07:01 +0100
To: bug-Catalyst-Controller-HTML-FormFu@rt.cpan.org
From: Sven Eppler <sven@sveneppler.de>
Hi There, just wanted to let you know, that after Catalyst 5.8 the "use base 'Catalyst::Controller::HTML::FormFu';" doesn't work anymore. Somewhere should be stated that now you should use "extends" provided by Moose which is currently encapsulated in an BEGIN-block: Controller created with myapp_create.pl: package MyApp; BEGIN {extends 'Catalyst::Controller'; } Becomes to: package MyApp; BEGIN {extends 'Catalyst::Controller::HTML::FormFu'; } Bye, Sven
Am Fr 29. Jan 2010, 09:08:34, sven@sveneppler.de schrieb:
Show quoted text
> Hi There, > > just wanted to let you know, that after Catalyst 5.8 the "use base > 'Catalyst::Controller::HTML::FormFu';" doesn't work anymore. > > Somewhere should be stated that now you should use "extends" provided by > Moose which is currently encapsulated in an BEGIN-block: > > Controller created with myapp_create.pl: > package MyApp; > BEGIN {extends 'Catalyst::Controller'; } > > Becomes to: > package MyApp; > BEGIN {extends 'Catalyst::Controller::HTML::FormFu'; } > > Bye, > Sven >
Hi Sven, di you have any problems with "use base"? Moose classes are still regular perl classes which you can subclass. So that shouldn't be a problem. Cheers, mo


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.