Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 5410
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: steve [...] fisharerojo.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.23
Fixed in: 0.24



Subject: Module::Build::Compat::write_makefile broken in 0.23
Download (untitled) / with headers
text/plain 606b
Modules that call Module::Build::Compat->write_makefile are unable to installed as is due to a change in that function. The error received is: Can't call method "find_perl_interpreter" on an undefined value at /usr/lib/perl5/site_perl/5.8.3/Module/Build/Compat.pm line 150. Looking at that function in Module::Build::Compat for versions 0.22 and 0.23, there is a change in the call to fake_makefile(). Overall, I've run into at least four CPAN modules that are unable to be installed through a CPAN shell due to this bug. They include: Pod::Coverage, File::Find::Rule, Plucene,and Plucene::Simple.
Download (untitled) / with headers
text/plain 109b
Yeah, I've fixed this problem in CVS but haven't released to CPAN yet. I should get out a new release soon.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.