This queue is for tickets about the DBD-Pg CPAN distribution.

Report information
The Basics
Id:
53879
Status:
stalled
Priority:
Low/Low
Queue:

People
Owner:
greg [...] turnstep.com
Requestors:
uncoolbob [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
2.16.1
Fixed in:
(no value)



Subject: DBD::Pg object version v2.16.1 does not match bootstrap parameter 2.16.1
Hello. I'm getting this error after installing the module (Perl info below) use DBI; use DBD::Pg; DBD::Pg object version v2.16.1 does not match bootstrap parameter 2.16.1 at /usr/lib/perl5/5.8.8/x86_64-linux-thread-multi/DynaLoader.pm line 253. I can't see exactly where the "v" is coming from (it's in the Makefile but not in Makefile.PL or any other file in the distribution). If I s/v2/2/g in Makefile it does actually fix the problem! Let me know if you need anything other than the following perl -V output Summary of my perl5 (revision 5 version 8 subversion 8) configuration: Platform: osname=linux, osvers=2.6.16, archname=x86_64-linux-thread-multi uname='linux gershwin 2.6.16 #1 smp tue may 10 17:15:56 utc 2005 x86_64 x86_64 x86_64 gnulinux ' config_args='-ds -e -Dprefix=/usr -Dvendorprefix=/usr -Dinstallusrbinperl -Dusethreads -Di_db -Di_dbm -Di_ndbm -Di_gdbm -Duseshrplib=true -Doptimize=-O2 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g -Wall -pipe' hint=recommended, useposix=true, d_sigaction=define usethreads=define use5005threads=undef useithreads=define usemultiplicity=define useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=define uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -pipe -Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g -Wall -pipe', cppflags='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -pipe -Wdeclaration-after-statement' ccversion='', gccversion='4.1.2 20070115 (prerelease) (SUSE Linux)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='cc', ldflags =' -L/usr/local/lib64' libpth=/lib64 /usr/lib64 /usr/local/lib64 libs=-lm -ldl -lcrypt -lpthread perllibs=-lm -ldl -lcrypt -lpthread libc=/lib64/libc-2.4.so, so=so, useshrplib=true, libperl=libperl.so gnulibc_version='2.4' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-rpath,/usr/lib/perl5/5.8.8/x86_64-linux-thread-multi/CORE' cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib64' Characteristics of this binary (from libperl): Compile-time options: DEBUGGING MULTIPLICITY PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP THREADS_HAVE_PIDS USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API Built under linux Compiled at Nov 9 2007 17:43:32 %ENV: PERL5LIB=".:/usr/local/vblibs/perl/ensembl_latest/ensembl/modules/:/usr/lib/perl5/5.8.5/x86_64-linux-thread-multi:/usr/lib/perl5/5.8.5:/usr/lib/perl5/site_perl/5.8.5/x86_64-linux-thread-multi:/usr/lib/perl5/site_perl/5.8.5:/usr/lib/perl5/site_perl:/usr/lib/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi:/usr/lib/perl5/vendor_perl/5.8.5:/usr/lib/perl5/vendor_perl:/usr/lib/perl5/5.8.8/x86_64-linux-thread-multi/CORE/:/usr/local/apache2/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/" @INC: . /usr/local/vblibs/perl/ensembl_latest/ensembl/modules/ /usr/lib/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/x86_64-linux-thread-multi/CORE/ /usr/local/apache2/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/ /usr/lib/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl . OS: Linux 2.6.16.54-0.2.5-smp #1 SMP Mon Jan 21 13:29:51 UTC 2008 x86_64 x86_64 x86_64 GNU/Linux SUSE 10.1 Thanks very much for maintaining this! Bob.
Could you send the version of ExtUtils::MakeMaker you have, as well as the output of: perl Makefile.PL
On Thu Jan 21 07:40:43 2010, greg@turnstep.com wrote:
Show quoted text
> Could you send the version of ExtUtils::MakeMaker you have, as well as > the output of: perl Makefile.PL
No problem. $ExtUtils::MakeMaker::VERSION == 6.56 export POSTGRES_HOME=/usr/local/pgsql_dir/postgresql-8.3.9 perl Makefile.PL Configuring DBD::Pg 2.16.1 PostgreSQL version: 80309 (default port: 5432) POSTGRES_HOME: /usr/local/pgsql_dir/postgresql-8.3.9 POSTGRES_INCLUDE: /usr/local/pgsql_dir/postgresql-8.3.9/include POSTGRES_LIB: /usr/local/pgsql_dir/postgresql-8.3.9/lib OS: linux Using DBI 1.609 (for perl 5.008008 on x86_64-linux-thread-multi) installed in /usr/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/ Writing Makefile for DBD::Pg many thanks!
That's quite unusual. Can you send the actual generated Makefile as well?
Subject: Re: [rt.cpan.org #53879] DBD::Pg object version v2.16.1 does not match bootstrap parameter 2.16.1
Date: Fri, 22 Jan 2010 16:04:28 +0000
To: bug-DBD-Pg@rt.cpan.org
From: Bob MacCallum <uncoolbob@gmail.com>

Message body is not shown because it is too large.

Message body is not shown because it is too large.

Don't think it's EU:MM, maybe the version module itself? Can you give the output of: perl -Mversion -e 'print $version::VERSION'
Subject: Re: [rt.cpan.org #53879] DBD::Pg object version v2.16.1 does not match bootstrap parameter 2.16.1
Date: Sun, 7 Feb 2010 11:36:18 +0000
To: bug-DBD-Pg@rt.cpan.org
From: Bob MacCallum <uncoolbob@gmail.com>
0.76

(never heard of the version module until now!)

On Sun, Feb 7, 2010 at 5:22 AM, Greg Sabino Mullane via RT <bug-DBD-Pg@rt.cpan.org> wrote:
Show quoted text
Don't think it's EU:MM, maybe the version module itself? Can you give
the output of:

perl -Mversion -e 'print $version::VERSION'





--
http://darwintunes.org - a test-tube for cultural evolution
http://evolectronica.com - survival of the funkiest
http://compare-stuff.com - confused? you will be!
http://twitter.com/darwintunes
http://twitter.com/bobmaccallum
Can you try this on a newer version (latest is 2.17.2 as of this writing)?


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.