Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 53779
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: REHSACK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.3601
Fixed in: (no value)



Subject: t/properties/needs_compiler.t broken
Hi, during update, t/properties/needs_compiler.t fails - test again after update, everything (except separately reported hidden compiler test) seems to be ok: bash-4.0$ (cd work/Module-Build-0.3601/ && perl -Iblib/lib t/properties/needs_compiler.t) 1..19 ok 1 - Default Build.PL ok 2 - needs_compiler is false ok 3 - ExtUtils::CBuilder is not in build_requires ok 4 - Build.PL with c_source ok 5 - c_source is set not ok 6 - needs_compiler is true # Failed test 'needs_compiler is true' # at t/properties/needs_compiler.t line 41. not ok 7 - ExtUtils::CBuilder was added to build_requires # Failed test 'ExtUtils::CBuilder was added to build_requires' # at t/properties/needs_compiler.t line 42. ok 8 - Build.PL with xs files not ok 9 - needs_compiler is true # Failed test 'needs_compiler is true' # at t/properties/needs_compiler.t line 58. not ok 10 - ExtUtils::CBuilder was added to build_requires # Failed test 'ExtUtils::CBuilder was added to build_requires' # at t/properties/needs_compiler.t line 59. ok 11 - Build.PL with xs files, but needs_compiler => 0 ok 12 - needs_compiler is false ok 13 - ExtUtils::CBuilder is not in build_requires ok 14 - Build.PL with xs files, build_requires EU::CB 0.2 not ok 15 - needs_compiler is true # Failed test 'needs_compiler is true' # at t/properties/needs_compiler.t line 100. ok 16 - build_requires for ExtUtils::CBuilder is correct version ok 17 - Build.PL while hiding compiler not ok 18 - hidden compiler resulted in warning message during Build.PL # Failed test 'hidden compiler resulted in warning message during Build.PL' # at t/properties/needs_compiler.t line 113. # '* WARNING: Configuration was initially created with Module::Build # version '0.35' but we are now using version '0.3601'. # If errors occur, you must re-run the Build.PL or Makefile.PL script. # ' # doesn't match '(?-xism:no compiler detected)' ok 19 - hidden compiler resulted in fatal message during Build # Looks like you failed 6 tests of 19. Maybe, Build.PL of Module::Build should use it's "bundled" Module::Build, if possible. /Jens
Download (untitled) / with headers
text/plain 498b
Show quoted text
> Maybe, Build.PL of Module::Build should use it's "bundled" > Module::Build, if possible.
It generally does, so this error is quite odd. Show quoted text
> bash-4.0$ (cd work/Module-Build-0.3601/ && perl -Iblib/lib > t/properties/needs_compiler.t)
What happens if you do this: $ cd work/Module-Build-0.3601 $ perl Build.PL $ Build test --verbose --test_files=t/properties/needs_compiler.t I suspect you'll see just test 18 fail, which is ticket https://rt.cpan.org/Ticket/Display.html?id=53296 -- David
Patch for other ticket has been released to CPAN. Please try with 0.3602.
Download (untitled) / with headers
text/plain 103b
Now that there has been a stable Module::Build release, I'm marking this "patched" issue as "resolved".


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.