This queue is for tickets about the IO-Prompt CPAN distribution.

Report information
The Basics
Id:
53510
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
JHTHORSEN [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
v0.99.4
Fixed in:
(no value)



Subject: problem with non-decimal version number
I'm trying to depend on your module, but it's really difficult when module::install / extutils::makemaker complains about your version number:

$ cat Makefile.PL
use inc::Module::Install;
requires q(IO::Prompt) => "0.99"
WriteAll;

$ perl Makefile.PL
*** Module::AutoInstall version 1.03
*** Checking for Perl dependencies...
[Core Features]
- IO::Prompt      ...missing. (would need 0.99)
Show quoted text
==> Auto-install the 1 mandatory module(s) from CPAN? [y]

Could you change version format to a decimal, like "0.99004"?
Subject: Re: [rt.cpan.org #53510] problem with non-decimal version number
Date: Sun, 10 Jan 2010 20:22:58 +1100
To: bug-IO-Prompt@rt.cpan.org
From: Damian Conway <damian@conway.org>
Show quoted text
> Could you change version format to a decimal, like "0.99004"?
Changed and uploaded. Damian


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.