Skip Menu |
 

This queue is for tickets about the autodie CPAN distribution.

Report information
The Basics
Id: 53506
Status: resolved
Priority: 0/
Queue: autodie

People
Owner: Nobody in particular
Requestors: james2vegas [...] aim.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 2.06
Fixed in: 2.15



Subject: Perl 5.8.2 failing t/caller.t
$ perl -v

This is perl, v5.8.2 built for i386-freebsd

Copyright 1987-2003, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

$ prove --verbose --blib t/caller.t
t/caller.t ..
Can't upgrade that kind of scalar at t/caller.t line 26.
Show quoted text
# Looks like your test exited with 255 before it could output anything.
Dubious, test returned 255 (wstat 65280, 0xff00)
No subtests run

Test Summary Report
-------------------
t/caller.t (Wstat: 65280 Tests: 0 Failed: 0)
  Non-zero exit status: 255
  Parse errors: No plan found in TAP output
Files=1, Tests=0,  0 wallclock secs ( 0.03 usr  0.02 sys +  0.20 cusr  0.01 csys =  0.25 CPU)
Result: FAIL
$

Download (untitled) / with headers
text/plain 628b
G'day James, On Fri Jan 08 01:32:23 2010, JWRIGHT wrote: Show quoted text
> $ perl -v > > This is perl, v5.8.2 built for i386-freebsd
I'm really sorry, but 5.8.2 is a *very* old version of Perl, and there have been many new releases in the 5.8.x branch since then. I wish I had the time to down down bugs with autodie in very old versions of Perl, but there's an excellent chance this may be tickling a bug in perl itself, which can only be properly fixed by upgrading perl. If you're still encountering these same issues on a recent 5.8.x release (at least 5.8.5, and preferably 5.8.8 or 5.8.9), then do let me know. All the best, Paul
Well, that is all fine, except that if you require a newer version of Perl as a minimum, you should adjust your META.yml to reflect that the latest supported version is 5.8.5, not 5.8.0.

 
Still has 5.8.0 as the minimum required Perl version, not something > 5.8.2
Download (untitled) / with headers
text/plain 436b
On Mon Feb 22 13:58:48 2010, JWRIGHT wrote: Show quoted text
> Still has 5.8.0 as the minimum required Perl version, not something > 5.8.2
Hi, Judging from the Changes file, this was fixed in v2.15[0]. I am marking this as resolved with v2.15 as first fixed version. ~Niels [0] Technically there was a fix in v2.14, but it typo'ed the version and required v5.8.40 instead of v5.8.4. I figured it would be better to consider that as "broken". :)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.