Skip Menu |
 

This queue is for tickets about the Module-Setup CPAN distribution.

Report information
The Basics
Id: 53093
Status: resolved
Priority: 0/
Queue: Module-Setup

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.07
Fixed in: (no value)



Subject: Undeclared dependency on LWP::UserAgent
Download (untitled) / with headers
text/plain 1.8k
I just verified manually the claim in the subject. LWP::UserAgent is not declared a prerequisite yet a grep reveils % grep -rn LWP::UserAgent . ./lib/Module/Setup/Plugin/Site/GitHub.pm:6:use LWP::UserAgent; ./lib/Module/Setup/Plugin/Site/GitHub.pm:94: my $ua = LWP::UserAgent->new( ./t/030_plugin/site_github.t:6:use Test::Requires qw( JSON LWP::UserAgent ); it is used in several places. The fail I got looked like so: Can't locate LWP/UserAgent.pm in @INC (@INC contains: /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/inc /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/lib /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/arch /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157-g0f907b9/lib/site_perl/5.11.2/x86_64-linux-ld /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157-g0f907b9/lib/site_perl/5.11.2 /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157-g0f907b9/lib/5.11.2/x86_64-linux-ld /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157-g0f907b9/lib/5.11.2 .) at /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/lib/Module/Setup/Plugin/Site/GitHub.pm line 6, <DATA> line 1. BEGIN failed--compilation aborted at /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/lib/Module/Setup/Plugin/Site/GitHub.pm line 6, <DATA> line 1. Compilation failed in require at (eval 115) line 2, <DATA> line 1. at /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/lib/Module/Setup/Test/Utils.pm line 91 # Looks like your test exited with 2 before it could output anything. t/040_flavor/github.t ............................. Dubious, test returned 2 (wstat 512, 0x200) Failed 22/22 subtests cannot remove path when cwd is /tmp/IEQy0JEjf4 for /tmp/IEQy0JEjf4: at /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157-g0f907b9/lib/5.11.2/File/Temp.pm line 2445 t/050_helper/basic-callback.t ..................... ok HTH,
thanks to you for report. this problem is just fixed in 0.08. On 2009-12꜈-25 金 03:08:38, ANDK wrote: Show quoted text
> I just verified manually the claim in the subject. > > LWP::UserAgent is not declared a prerequisite yet a grep reveils > > % grep -rn LWP::UserAgent . > ./lib/Module/Setup/Plugin/Site/GitHub.pm:6:use LWP::UserAgent; > ./lib/Module/Setup/Plugin/Site/GitHub.pm:94: my $ua = > LWP::UserAgent->new( > ./t/030_plugin/site_github.t:6:use Test::Requires qw( JSON > LWP::UserAgent ); > > it is used in several places. > > The fail I got looked like so: > > Can't locate LWP/UserAgent.pm in @INC (@INC contains: > /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/inc > /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/lib > /home/sand/.cpan/build/Module-Setup-0.07-jsgBP_/blib/arch > /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157- > g0f907b9/lib/site_perl/5.11.2/x86_64-linux-ld > /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157- > g0f907b9/lib/site_perl/5.11.2 > /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157- > g0f907b9/lib/5.11.2/x86_64-linux-ld > /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157- > g0f907b9/lib/5.11.2 > .) at > /home/sand/.cpan/build/Module-Setup-0.07- > jsgBP_/blib/lib/Module/Setup/Plugin/Site/GitHub.pm > line 6, <DATA> line 1. > BEGIN failed--compilation aborted at > /home/sand/.cpan/build/Module-Setup-0.07- > jsgBP_/blib/lib/Module/Setup/Plugin/Site/GitHub.pm > line 6, <DATA> line 1. > Compilation failed in require at (eval 115) line 2, <DATA> line 1. > at > /home/sand/.cpan/build/Module-Setup-0.07- > jsgBP_/blib/lib/Module/Setup/Test/Utils.pm > line 91 > # Looks like your test exited with 2 before it could output anything. > t/040_flavor/github.t ............................. > Dubious, test returned 2 (wstat 512, 0x200) > Failed 22/22 subtests > cannot remove path when cwd is /tmp/IEQy0JEjf4 for /tmp/IEQy0JEjf4: > at > /home/src/perl/repoperls/installed-perls/perl/v5.11.2-157- > g0f907b9/lib/5.11.2/File/Temp.pm > line 2445 > t/050_helper/basic-callback.t ..................... ok > > > > HTH,


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.