Skip Menu |
 

This queue is for tickets about the CPANPLUS CPAN distribution.

Report information
The Basics
Id: 52717
Status: stalled
Worked: 5 min
Priority: 0/
Queue: CPANPLUS

People
Owner: BINGOS [...] cpan.org
Requestors: APOCAL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: CPANPLUS v0.89_12 not sending N/A or UNKNOWN for module on old perl?
Download (untitled) / with headers
text/plain 8.5k
Hello, I may be totally off base but I sorta expected a report to be submitted, but I saw CPANPLUS not doing anything. What I did was use POE::Component::SmokeBox and tried to smoke Acme::Anything on my perls. On perl-5.10.1 for example, it smoked and sent the test report just fine. On perl-5.6.2, the Makefile.PL bombed out because it required perl-5.8x, which is fine. However, you can see that CPANPLUS never sent any report afterwards. If this is the expected behavior then please discard this report! POE::Component::SmokeBox v0.30 CPANPLUS v0.89_12 CPANPLUS::YACSmoke v0.46 { 'PID' => 10553, 'env' => { 'PERL5_YACSMOKE_BASE' => '/home/cpan/cpanp_conf/perl-5.6.2-default/', 'APPDATA' => '/home/cpan/cpanp_conf/perl-5.6.2-default/' }, 'status' => '0', 'start_time' => 1260650731, 'perl' => '/home/cpan/perls/perl-5.6.2-default/bin/perl', 'end_time' => 1260650736, 'log' => [ '[MSG] Retrieving /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/sourcefiles.s2.21.c0.89_12.stored', '[MSG] Using cached file \'/home/cpan/.cpanplus/authors/CHECKSUMS\' on disk; ttl (3600s) is not exceeded', '[MSG] Checksum matches for \'Acme-Anything-0.03.tar.gz\'', '[MSG] Extracted \'Acme-Anything-0.03/\'', '[MSG] Extracted \'Acme-Anything-0.03/MANIFEST\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/Acme/\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/Acme/Anything.pm\'', '[MSG] Extracted \'Acme-Anything-0.03/Makefile.PL\'', '[MSG] Extracted \'Acme-Anything-0.03/Changes\'', '[MSG] Extracted \'Acme-Anything-0.03/README\'', '[MSG] Extracted \'Acme-Anything-0.03/META.yml\'', '[MSG] Extracted \'Acme-Anything-0.03/t/\'', '[MSG] Extracted \'Acme-Anything-0.03/t/00-load.t\'', '[MSG] Extracted \'Acme::Anything\' to \'/home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03\'', '[MSG] CPANPLUS is prefering Build.PL', '[MSG] Loading YACSmoke database "/home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/cpansmoke.dat"', 'Running [/home/cpan/perls/perl-5.6.2-default/bin/perl /home/cpan/perls/perl-5.6.2-default/bin/cpanp-run-perl /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03/Makefile.PL]...', 'Perl v5.8.0 required--this is only v5.6.2, stopped at /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03/Makefile.PL line 3.', 'BEGIN failed--compilation aborted at /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03/Makefile.PL line 3.', '[ERROR] Could not run \'/home/cpan/perls/perl-5.6.2-default/bin/perl Makefile.PL\': Perl v5.8.0 required--this is only v5.6.2, stopped at /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03/Makefile.PL line 3.', 'BEGIN failed--compilation aborted at /home/cpan/cpanp_conf/perl-5.6.2-default/.cpanplus/5.6.2/build/Acme-Anything-0.03/Makefile.PL line 3.', ' -- cannot continue', '', '[ERROR] Unable to create a new distribution object for \'Acme::Anything\' -- cannot continue', '', 'Key \'ok\' () is of invalid type for \'CPANPLUS::Backend::RV::new\' provided by CPANPLUS::Backend::__ANON__ at /home/cpan/perls/perl-5.6.2-default/lib/site_perl/5.6.2/CPANPLUS/Backend.pm line 398', '[MSG] Writing compiled source information to disk. This might take a little while.', 'CHLD 10553 0' ], 'type' => 'CPANPLUS::YACSmoke', 'module' => 'Acme::Anything', 'command' => 'smoke' }, { 'PID' => 10484, 'env' => { 'PERL5_YACSMOKE_BASE' => '/home/cpan/cpanp_conf/perl-5.10.1-default/', 'APPDATA' => '/home/cpan/cpanp_conf/perl-5.10.1-default/' }, 'status' => '0', 'start_time' => 1260650726, 'perl' => '/home/cpan/perls/perl-5.10.1-default/bin/perl', 'end_time' => 1260650731, 'log' => [ '[MSG] Retrieving /home/cpan/cpanp_conf/perl-5.10.1-default/.cpanplus/sourcefiles.s2.21.c0.89_12.stored', '[MSG] Using cached file \'/home/cpan/.cpanplus/authors/CHECKSUMS\' on disk; ttl (3600s) is not exceeded', '[MSG] Checksum matches for \'Acme-Anything-0.03.tar.gz\'', '[MSG] Extracted \'Acme-Anything-0.03/\'', '[MSG] Extracted \'Acme-Anything-0.03/MANIFEST\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/Acme/\'', '[MSG] Extracted \'Acme-Anything-0.03/lib/Acme/Anything.pm\'', '[MSG] Extracted \'Acme-Anything-0.03/Makefile.PL\'', '[MSG] Extracted \'Acme-Anything-0.03/Changes\'', '[MSG] Extracted \'Acme-Anything-0.03/README\'', '[MSG] Extracted \'Acme-Anything-0.03/META.yml\'', '[MSG] Extracted \'Acme-Anything-0.03/t/\'', '[MSG] Extracted \'Acme-Anything-0.03/t/00-load.t\'', '[MSG] Extracted \'Acme::Anything\' to \'/home/cpan/cpanp_conf/perl-5.10.1-default/.cpanplus/5.10.1/build/Acme-Anything-0.03\'', '[MSG] CPANPLUS is prefering Build.PL', '[MSG] Loading YACSmoke database "/home/cpan/cpanp_conf/perl-5.10.1-default/.cpanplus/cpansmoke.dat"', 'Running [/home/cpan/perls/perl-5.10.1-default/bin/perl /home/cpan/perls/perl-5.10.1-default/bin/cpanp-run-perl /home/cpan/cpanp_conf/perl-5.10.1-default/.cpanplus/5.10.1/build/Acme-Anything-0.03/Makefile.PL]...', 'Checking if your kit is complete...', 'Looks good', 'Writing Makefile for Acme::Anything', '[MSG] Checking for previous PASS result for "Acme-Anything-0.03"', '[MSG] Module \'Acme::Anything\' depends on \'Test::More\', may need to build a \'CPANPLUS::Dist::YACSmoke\' package for it as well', 'Running [/usr/bin/make]...', 'cp lib/Acme/Anything.pm blib/lib/Acme/Anything.pm', 'Running [/usr/bin/make test]...', 'PERL_DL_NONLAZY=1 /home/cpan/perls/perl-5.10.1-default/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, \'blib/lib\', \'blib/arch\')" t/*.t', '# Testing Acme::Anything 0.03, Perl 5.010001, /home/cpan/perls/perl-5.10.1-default/bin/perl', 't/00-load.t .. ok', 'All tests successful.', 'Files=1, Tests=2, 0 wallclock secs ( 0.00 usr 0.03 sys + 0.01 cusr 0.05 csys = 0.09 CPU)', 'Result: PASS', '[MSG] Sending test report for \'Acme-Anything-0.03\'', '[MSG] Successfully sent \'pass\' report for \'Acme-Anything-0.03\'', '[MSG] Writing compiled source information to disk. This might take a little while.', 'CHLD 10484 0' ], 'type' => 'CPANPLUS::YACSmoke', 'module' => 'Acme::Anything', 'command' => 'smoke' }, -- ~Apocalypse
Subject: Re: [rt.cpan.org #52717] CPANPLUS v0.89_12 not sending N/A or UNKNOWN for module on old perl?
Date: Sun, 13 Dec 2009 11:27:57 +0000
To: Apocalypse via RT <bug-CPANPLUS [...] rt.cpan.org>
From: "Chris 'BinGOs' Williams" <chris [...] bingosnet.co.uk>
Download (untitled) / with headers
text/plain 754b
On Sat, Dec 12, 2009 at 04:00:23PM -0500, Apocalypse via RT wrote: Show quoted text
> Hello, > > I may be totally off base but I sorta expected a report to be > submitted, but I saw CPANPLUS not doing anything. What I did was use > POE::Component::SmokeBox and tried to smoke Acme::Anything on my perls. > > On perl-5.10.1 for example, it smoked and sent the test report just > fine. On perl-5.6.2, the Makefile.PL bombed out because it required > perl-5.8x, which is fine. However, you can see that CPANPLUS never sent > any report afterwards. If this is the expected behavior then please > discard this report! >
Yeah, this is expected behaviour for CPANPLUS. -- Chris Williams aka BinGOs PGP ID 0x4658671F http://www.gumbynet.org.uk ==========================
Download (untitled)
application/pgp-signature 189b

Message body not shown because it is not plain text.

Slating for further investigation when the test report stuff is broken out of CPANPLUS


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.