Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 52699
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: salvatore.bonaccorso [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: t/99_pmv.t test failure with new Perl::MinimumVersion 1.22
Date: Sat, 12 Dec 2009 10:04:01 +0100
To: bug-Module-Install [...] rt.cpan.org, 560626 [...] bugs.debian.org
From: Salvatore Bonaccorso <salvatore.bonaccorso [...] gmail.com>
Download (untitled) / with headers
text/plain 3.2k
Hi First of all, I agree that this is a failure of build when activating author tests. We in Debian Perl Group try to activate any test which is possible to quarantee best quality. During such a rebuild of package for Module::Install it fails to build. There was an update in Perl::MinimumVersion: 1.22 Wed 25 Nov 2009 - Negative length in 'splice' requires perl 5.5 (Alexandr Ciornii) - 'mkdir' with one argument requires perl 5.6 (Alexandr Ciornii) - 'substr' will not be checked if it is a method name (Alexandr Ciornii) - better tests and fix for 3-arg 'open' (Alexandr Ciornii) 1.21 Tue 24 Nov 2009 - Add 'bytes' to 5.6 pragma (Alexandr Ciornii) - Add support for "version numbers" like "v1.1.1" (Alexandr Ciornii) - Reimplement _three_argument_open, more tests (Alexandr Ciornii) Now check for 3-arg open is working. - Check 4-arg substr that requires perl 5.5 (Alexandr Ciornii) - Postfix foreach requires perl 5.004.05 (Alexandr Ciornii) - Scalar::Util::weaken requires perl 5.006 (Alexandr Ciornii) - P::MV itself found imcompatibility in 02_main.t with 5.5 (Alexandr Ciornii) Now Module::Install fails with: Show quoted text
> make[1]: Entering directory `/build/user-libmodule-install-perl_0.91-1-amd64-sefl0P/libmodule-install-perl-0.91' > PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t t/recursive/*.t > t/01_compile.t ....... ok > t/02_mymeta.t ........ ok > t/03_autoinstall.t ... skipped: Skipping dangerous test > t/04_version.t ....... ok > t/05_share.t ......... ok > t/06_ppport.t ........ ok > t/07_perl_version.t .. ok > t/08_dsl.t ........... ok > t/09_read.t .......... ok > t/10_test.t .......... ok > t/11_extraction.t .... ok > t/97_meta.t .......... ok > t/98_pod.t ........... ok > > # Failed test 'lib/Module/Install.pm' > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > # lib/Module/Install.pm requires 5.006 due to syntax > # version markers for 5.006: > # - _three_argument_open > > # Failed test 'lib/Module/Install/Bundle.pm' > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > # lib/Module/Install/Bundle.pm requires 5.006 due to syntax > # version markers for 5.006: > # - _mkdir_1_arg > > # Failed test 'lib/Module/Install/Admin/Bundle.pm' > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > # lib/Module/Install/Admin/Bundle.pm requires 5.006 due to syntax > # version markers for 5.006: > # - _mkdir_1_arg > # Looks like you failed 3 tests of 52. > t/99_pmv.t ........... > Dubious, test returned 3 (wstat 768, 0x300) > Failed 3/52 subtests > Failed 1/15 test programs. 3/243 subtests failed. > t/recursive/test.t ... ok > > Test Summary Report > ------------------- > t/99_pmv.t (Wstat: 768 Tests: 52 Failed: 3) > Failed tests: 2, 11, 26 > Non-zero exit status: 3 > Files=15, Tests=243, 12 wallclock secs ( 0.09 usr 0.03 sys + 10.66 cusr 0.89 csys = 11.67 CPU) > Result: FAIL > make[1]: *** [test_dynamic] Error 255
The full Bugreport is located at http://bugs.debian.org/560626 The problem is that in the tests there are used syntax not matching the required version in META.yml. Many thanks for considering looking into it, Bests Salvatore
Download signature.asc
application/pgp-signature 835b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 3.5k
Hi. Thanks for the heads-up. This is fixed in 0.93/0.94. Please reopen this if you still find problems. On 2009-12-12 Sat 04:04:26, salvatore.bonaccorso@gmail.com wrote: Show quoted text
> Hi > > First of all, I agree that this is a failure of build when activating > author tests. We in Debian Perl Group try to activate any test which > is > possible to quarantee best quality. During such a rebuild of package > for > Module::Install it fails to build. There was an update in > Perl::MinimumVersion: > > 1.22 Wed 25 Nov 2009 > - Negative length in 'splice' requires perl 5.5 (Alexandr > Ciornii) > - 'mkdir' with one argument requires perl 5.6 (Alexandr > Ciornii) > - 'substr' will not be checked if it is a method name > (Alexandr Ciornii) > - better tests and fix for 3-arg 'open' (Alexandr Ciornii) > > 1.21 Tue 24 Nov 2009 > - Add 'bytes' to 5.6 pragma (Alexandr Ciornii) > - Add support for "version numbers" like "v1.1.1" (Alexandr > Ciornii) > - Reimplement _three_argument_open, more tests (Alexandr > Ciornii) > Now check for 3-arg open is working. > - Check 4-arg substr that requires perl 5.5 (Alexandr Ciornii) > - Postfix foreach requires perl 5.004.05 (Alexandr Ciornii) > - Scalar::Util::weaken requires perl 5.006 (Alexandr Ciornii) > - P::MV itself found imcompatibility in 02_main.t with 5.5 > (Alexandr Ciornii) > > Now Module::Install fails with:
> > make[1]: Entering directory `/build/user-libmodule-install-
> perl_0.91-1-amd64-sefl0P/libmodule-install-perl-0.91'
> > PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
> "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t > t/recursive/*.t
> > t/01_compile.t ....... ok > > t/02_mymeta.t ........ ok > > t/03_autoinstall.t ... skipped: Skipping dangerous test > > t/04_version.t ....... ok > > t/05_share.t ......... ok > > t/06_ppport.t ........ ok > > t/07_perl_version.t .. ok > > t/08_dsl.t ........... ok > > t/09_read.t .......... ok > > t/10_test.t .......... ok > > t/11_extraction.t .... ok > > t/97_meta.t .......... ok > > t/98_pod.t ........... ok > > > > # Failed test 'lib/Module/Install.pm' > > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > > # lib/Module/Install.pm requires 5.006 due to syntax > > # version markers for 5.006: > > # - _three_argument_open > > > > # Failed test 'lib/Module/Install/Bundle.pm' > > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > > # lib/Module/Install/Bundle.pm requires 5.006 due to syntax > > # version markers for 5.006: > > # - _mkdir_1_arg > > > > # Failed test 'lib/Module/Install/Admin/Bundle.pm' > > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > > # lib/Module/Install/Admin/Bundle.pm requires 5.006 due to syntax > > # version markers for 5.006: > > # - _mkdir_1_arg > > # Looks like you failed 3 tests of 52. > > t/99_pmv.t ........... > > Dubious, test returned 3 (wstat 768, 0x300) > > Failed 3/52 subtests > > Failed 1/15 test programs. 3/243 subtests failed. > > t/recursive/test.t ... ok > > > > Test Summary Report > > ------------------- > > t/99_pmv.t (Wstat: 768 Tests: 52 Failed: 3) > > Failed tests: 2, 11, 26 > > Non-zero exit status: 3 > > Files=15, Tests=243, 12 wallclock secs ( 0.09 usr 0.03 sys + 10.66
> cusr 0.89 csys = 11.67 CPU)
> > Result: FAIL > > make[1]: *** [test_dynamic] Error 255
> > The full Bugreport is located at http://bugs.debian.org/560626 > > The problem is that in the tests there are used syntax not matching > the > required version in META.yml. > > Many thanks for considering looking into it, > Bests > Salvatore


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.