Skip Menu |
 

This queue is for tickets about the CPAN-Inject CPAN distribution.

Report information
The Basics
Id: 52697
Status: new
Priority: 0/
Queue: CPAN-Inject

People
Owner: Nobody in particular
Requestors: salvatore.bonaccorso [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: t/99_pmv.t test failure with new Perl::MinimumVersion 1.22
Date: Sat, 12 Dec 2009 09:52:02 +0100
To: bug-CPAN-Inject [...] rt.cpan.org, 560647 [...] bugs.debian.org
From: Salvatore Bonaccorso <salvatore.bonaccorso [...] gmail.com>
Download (untitled) / with headers
text/plain 2.3k
Hi First of all, I agree that this is a failure of build when activating author tests. We in Debian Perl Group try to activate any test which is possible to quarantee best quality. During such a rebuild of package for CPAN::Inject it fails to build. There was an update in Perl::MinimumVersion: 1.22 Wed 25 Nov 2009 - Negative length in 'splice' requires perl 5.5 (Alexandr Ciornii) - 'mkdir' with one argument requires perl 5.6 (Alexandr Ciornii) - 'substr' will not be checked if it is a method name (Alexandr Ciornii) - better tests and fix for 3-arg 'open' (Alexandr Ciornii) 1.21 Tue 24 Nov 2009 - Add 'bytes' to 5.6 pragma (Alexandr Ciornii) - Add support for "version numbers" like "v1.1.1" (Alexandr Ciornii) - Reimplement _three_argument_open, more tests (Alexandr Ciornii) Now check for 3-arg open is working. - Check 4-arg substr that requires perl 5.5 (Alexandr Ciornii) - Postfix foreach requires perl 5.004.05 (Alexandr Ciornii) - Scalar::Util::weaken requires perl 5.006 (Alexandr Ciornii) - P::MV itself found imcompatibility in 02_main.t with 5.5 (Alexandr Ciornii) Now CPAN::Inject fails with: Show quoted text
> make[2]: Entering directory > `/build/user-libcpan-inject-perl_0.11-1-amd64-3nDW4x/libcpan-inject-perl-0.11' > PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" > "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/01_compile.t > t/9*.t > t/01_compile.t .. ok > t/98_pod.t ...... ok > > # Failed test 't/02_main.t' > # at /usr/share/perl5/Test/MinimumVersion.pm line 150. > # t/02_main.t requires 5.006 due to syntax > # version markers for 5.006: > # - _mkdir_1_arg > # Looks like you failed 1 test of 6. > t/99_pmv.t ...... > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/6 subtests > > Test Summary Report > ------------------- > t/99_pmv.t (Wstat: 256 Tests: 6 Failed: 1) > Failed test: 3 > Non-zero exit status: 1 > Files=3, Tests=11, 3 wallclock secs ( 0.03 usr 0.01 sys + 1.26 > cusr 0.08 csys = 1.38 CPU) > Result: FAIL > Failed 1/3 test programs. 1/11 subtests failed. > make[2]: *** [test_dynamic] Error 1
The full Bugreport is located at http://bugs.debian.org/560647 The problem is that in the tests there are used syntax not matching the required version in META.yml. Many thanks for considering looking into it, Bests Salvatore
Download signature.asc
application/pgp-signature 835b

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.