Skip Menu |
 

This queue is for tickets about the Algorithm-Diff-Any CPAN distribution.

Report information
The Basics
Id: 52656
Status: resolved
Priority: 0/
Queue: Algorithm-Diff-Any

People
Owner: JAWNSY [...] cpan.org
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.000
Fixed in: (no value)



Subject: Minimum required version of Exporter is 5.57 or thereabouts
Download (untitled) / with headers
text/plain 478b
The dependency on the Exporter is missing and should be added and specified with version 5.57. That's because the use Exporter 'import'; idiom which I can see in lib/Algorithm/Diff/Any.pm was invented on that release. Users of 5.8.2 and older will often not have the right Exporter installed although it is available on CPAN. See for example the first FAIL of eleven reports on this error: http://www.nntp.perl.org/group/perl.cpan.testers/2009/12/msg6334862.html Thanks,
Download (untitled) / with headers
text/plain 104b
Marking this as resolved now, as this issue seems to be fixed in 1.001. Thanks very much for the report!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.