Skip Menu |
 

This queue is for tickets about the DBD-SQLite CPAN distribution.

Report information
The Basics
Id: 5265
Status: resolved
Priority: 0/
Queue: DBD-SQLite

People
Owner: Nobody in particular
Requestors: robbin.bonthond [...] philips.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.29
Fixed in: (no value)



Subject: DBD-SQlite 0.30 on HPUX11
Download (untitled) / with headers
text/plain 4.1k
Hello, I am trying to install DBD-SQLite v0.30 on HPUX 11: bonthond@dscc10 $ uname -a HP-UX dscc10 B.11.11 U 9000/785 2014069888 unlimited-user license I get the following error when trying to compile: $ perl Makefile.PL Checking if your kit is complete... Looks good Warning: prerequisite DBI 1.21 not found at (eval 1) line 220. Using DBI 1.13 installed in /cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI Writing Makefile for DBD::SQLite $ make mkdir blib mkdir blib/lib mkdir blib/lib/DBD mkdir blib/arch mkdir blib/arch/auto mkdir blib/arch/auto/DBD mkdir blib/arch/auto/DBD/SQLite mkdir blib/lib/auto mkdir blib/lib/auto/DBD mkdir blib/lib/auto/DBD/SQLite mkdir blib/man3 cp getsqlite.pl blib/lib/DBD/getsqlite.pl cp lib/DBD/SQLite.pm blib/lib/DBD/SQLite.pm /cadappl/bin/perl -p -e "s/~DRIVER~/SQLite/g" < /cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI/Driver.xst > SQLite.xsi /cadappl/bin/perl -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1 -I/cadappl/perl/5.00503/lib/5.00503 /cadappl/perl/5.00503/lib/5.00503/ExtUtils/xsubpp -typemap /cadappl/perl/5.00503/lib/5.00503/ExtUtils/typemap SQLite.xs >xstmp.c && mv xstmp.c SQLite.c cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE SQLite.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE attach.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE auth.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE btree.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE btree_rb.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE build.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE copy.c cc: warning 459: Invalid argument for option 6. cc -c -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI -D_HPUX_SOURCE -Aa -I/usr/local/include -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" +z -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE date.c cc: warning 459: Invalid argument for option 6. cpp: "/usr/include/sys/stdsyms.h", line 368: error 4062: "Large Files (ILP32) not supported in strict ANSI mode." *** Error exit code 1 Stop.
Download (untitled) / with headers
text/plain 4.6k
[guest - Mon Feb 9 06:09:06 2004]: Hello, I fixed it by adding the option -Ae to CCCDLFLAGS in the generated Makefile. With regards, Robbin Show quoted text
> Hello, > > I am trying to install DBD-SQLite v0.30 on HPUX 11: > bonthond@dscc10 $ uname -a > HP-UX dscc10 B.11.11 U 9000/785 2014069888 unlimited-user license > > I get the following error when trying to compile: > > $ perl Makefile.PL > Checking if your kit is complete... > Looks good > Warning: prerequisite DBI 1.21 not found at (eval 1) line 220. > Using DBI 1.13 installed in > /cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > Writing Makefile for DBD::SQLite > $ make > mkdir blib > mkdir blib/lib > mkdir blib/lib/DBD > mkdir blib/arch > mkdir blib/arch/auto > mkdir blib/arch/auto/DBD > mkdir blib/arch/auto/DBD/SQLite > mkdir blib/lib/auto > mkdir blib/lib/auto/DBD > mkdir blib/lib/auto/DBD/SQLite > mkdir blib/man3 > cp getsqlite.pl blib/lib/DBD/getsqlite.pl > cp lib/DBD/SQLite.pm blib/lib/DBD/SQLite.pm > /cadappl/bin/perl -p -e "s/~DRIVER~/SQLite/g" < > /cadappl/perl/5.00503/lib/site_perl/5.005/PA- > RISC1.1/auto/DBI/Driver.xst > SQLite.xsi > /cadappl/bin/perl > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1 > -I/cadappl/perl/5.00503/lib/5.00503 > /cadappl/perl/5.00503/lib/5.00503/ExtUtils/xsubpp -typemap > /cadappl/perl/5.00503/lib/5.00503/ExtUtils/typemap SQLite.xs
> >xstmp.c && mv xstmp.c SQLite.c
> cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE SQLite.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE attach.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE auth.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE btree.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE btree_rb.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE build.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE copy.c > cc: warning 459: Invalid argument for option 6. > cc -c > -I/cadappl/perl/5.00503/lib/site_perl/5.005/PA-RISC1.1/auto/DBI > -D_HPUX_SOURCE -Aa -I/usr/local/include > -I/sys/DTC_source/sysutils/perl5/5.005_03/GNUdbm/include -O6 > -DNDEBUG=1 -DSQLITE_PTR_SZ=4 -DVERSION=\"0.30\" > -DXS_VERSION=\"0.30\" +z > -I/cadappl/perl/5.00503/lib/5.00503/PA-RISC1.1/CORE date.c > cc: warning 459: Invalid argument for option 6. > cpp: "/usr/include/sys/stdsyms.h", line 368: error 4062: "Large Files > (ILP32) not supported in strict ANSI mode." > *** Error exit code 1 > > Stop.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.