This queue is for tickets about the Catalyst-Devel CPAN distribution.

Report information
The Basics
Id:
52543
Status:
resolved
Priority:
Low/Low

People
Owner:
bobtfish [...] bobtfish.net
Requestors:
m.nooning [...] comcast.net
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.23
Fixed in:
(no value)



Subject: t/generated_app.t Failed test 'script\testapp_cgi.pl is executable'
I added a "Reply" to a 1.22 bug report for t/generated_app.t, but it was closed, and hence did not reopen the ticket. I will retry here. Sorry if it is redundant. On Windows XP, Perl 5.8.8, I get maybe six test failures of the form below. # Failed test 'script\testapp_cgi.pl is executable' # at t/generated_app.t line 124. I am trying to install Catalyst-Authentication-Store-DBIx-Class-0.1082, which depends upon Catalyst::Model::DBIC::Schema, which needs Catalyst::Devel. In addition, doing "prove t\generated_app.t" does not work. Thanks
Show quoted text
--------Paste output from nmake test ------- C:\temp\Catalyst-Devel-1.23>nmake test Microsoft (R) Program Maintenance Utility Version 9.00.30729.01 Copyright (C) Microsoft Corporation. All rights reserved. C:\Perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib\lib', 'blib\arch')" t/01use.t t/02pod.t t/03podcoverage.t t/back_compat.t t/generated_app.t t/get_sharedir_file.t t/optional_http- server-restart.t t/render_file_contents.t t/render_share_dir_file.t t/01use.t ......................... ok t/02pod.t ......................... skipped: set TEST_POD to enable this test t/03podcoverage.t ................. skipped: set TEST_POD to enable this test t/back_compat.t ................... ok t/generated_app.t ................. # Generated app is in C:\DOCUME~1\Malcolm\LOCALS~1\Temp\cTGCY9eKAh t/generated_app.t ................. 4/? # Failed test 'script\testapp_cgi.pl is executable' # at t/generated_app.t line 124. t/generated_app.t ................. 25/? # Failed test 'script\testapp_fastcgi.pl is executable' # at t/generated_app.t line 124. # Failed test 'script\testapp_server.pl is executable' # at t/generated_app.t line 124. t/generated_app.t ................. 31/? # Failed test 'script\testapp_test.pl is executable' # at t/generated_app.t line 124. # Failed test 'script\testapp_create.pl is executable' # at t/generated_app.t line 124. t/generated_app.t ................. 44/? # Failed test 'Exit status ok for 'make'' # at t/generated_app.t line 108. # got: '2' # expected: '0' # STDOUT: # STDERR: # "make": *** No rule to make target `C:\Perl\libConfig.pm', needed by `Makefile'. Stop. t/generated_app.t ................. 47/? You said to run 0 tests at t\02pod.t line 10. Compilation failed in require at t/generated_app.t line 140. # Child (Generated app test: t\02pod.t) exited without calling finalize() # Failed test 'Generated app test: t\02pod.t' # at C:/Perl/site/lib/Test/Builder.pm line 227. # Tests were run but no plan was declared and done_testing() was not seen. cannot remove path when cwd is C:/DOCUME~1/Malcolm/LOCALS~1/Temp/cTGCY9eKAh/TestApp for C:\DOCUME~1\Malcolm\LO CALS~1\Temp\cTGCY9eKAh: at C:/Perl/site/lib/File/Temp.pm line 902 t/generated_app.t ................. Dubious, test returned 9 (wstat 2304, 0x900) Failed 7/48 subtests t/get_sharedir_file.t ............. ok t/optional_http-server-restart.t .. skipped: set TEST_HTTP to enable this test t/render_file_contents.t .......... ok t/render_share_dir_file.t ......... ok Test Summary Report ------------------- t/generated_app.t (Wstat: 2304 Tests: 48 Failed: 7) Failed tests: 24, 27, 30, 33, 36, 46, 48 Non-zero exit status: 9 Parse errors: No plan found in TAP output Files=9, Tests=62, 16 wallclock secs ( 0.09 usr + 0.06 sys = 0.16 CPU) Result: FAIL Failed 1/9 test programs. 7/62 subtests failed. NMAKE : fatal error U1077: 'C:\Perl\bin\perl.exe' : return code '0xff' Stop. C:\temp\Catalyst-Devel-1.23> --------Paste output from prove t\generated_app.t" ------- C:\temp\Catalyst-Devel-1.23>prove t\generated_app.t t\generated_app.t .. Can't locate Catalyst/Devel.pm in @INC (@INC contains: C:/Perl/site/lib C:/Perl/lib .) at t\generated_app.t line 8. BEGIN failed--compilation aborted at t\generated_app.t line 8. t\generated_app.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run Test Summary Report ------------------- t\generated_app.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output Files=1, Tests=0, 0 wallclock secs ( 0.03 usr + 0.00 sys = 0.03 CPU) Result: FAIL Thanks
There have been some additional win32 fixes, see: http://lists.scsys.co.uk/pipermail/catalyst/2009-December/024030.html http://dev.catalyst.perl.org/svnweb/Catalyst/revision/?rev=12224 These (and some other fixes) are going to be released as 1.24 shortly.
Subject: Re: [rt.cpan.org #52543] t/generated_app.t Failed test 'script\testapp_cgi.pl is executable'
Date: Mon, 07 Dec 2009 18:37:59 -0500
To: bug-Catalyst-Devel@rt.cpan.org
From: Malcolm Nooning <m.nooning@comcast.net>
Yay!!!! All tests successful. Files=9, Tests=69, 21 wallclock secs ( 0.14 usr + 0.00 sys = 0.14 CPU) Result: PASS Thanks for the quick response, too Tomas Doran via RT wrote:
Show quoted text


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.