This queue is for tickets about the Catalyst-Devel CPAN distribution.

Report information
The Basics
Id:
52386
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
andreas.marienborg [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
(no value)
Fixed in:
(no value)



Subject: SCRIPT_GEN not checked early enough.
I have some applications with CATALYST_SCRIPT_GEN = 32, and when I try to start the server with -r it doesn't report that my scripts are out of date, it dies with could not locate Catalyst::Engine::HTTP::Restarter. This happens if I have new versions of Catalyst::Devel and Catalyst, which removed that engine in favour of the new code in Catalyst::Devel
This can't be solved as the loading of that engine is done by the script, which can't be fixed without incrementing SCRIPT_GEN. Bummer eh? I'm going to close this, but feel free to reopen if you have any suggestions about how we could actually do this.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.