Skip Menu |
 

This queue is for tickets about the URI CPAN distribution.

Report information
The Basics
Id: 52009
Status: open
Priority: 0/
Queue: URI

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.50
Fixed in: (no value)



Subject: Undeclared dependencies
Download (untitled) / with headers
text/plain 513b
On cpantesters I found both of http://nntp.x.perl.org/group/perl.cpan.testers/6109574 : Can't locate integer.pm http://nntp.x.perl.org/group/perl.cpan.testers/6129905 : Can't locate Encode.pm The latter hits mostly on 5.6.2 systems but could also come from systems that deliberately decide to run without Encode. The former is a bit weird, I wasn't aware that there are systems without integer.pm but one learns something new every day:) I'd suggest to declare these prereqs. Best wishes from Old Europe:)
Download (untitled) / with headers
text/plain 779b
On Mon Nov 23 15:19:59 2009, ANDK wrote: Show quoted text
> On cpantesters I found both of > > http://nntp.x.perl.org/group/perl.cpan.testers/6109574 : Can't locate > integer.pm
The first one is just the effect of some old bad code that wasn't portable to windows. Fixed in <http://github.com/gisle/uri/commit/8f282e9fffd7f22e583757d4230b30366e50f98e>. I don't think there should be a need to be explict about 'integer' since it's just a standard part of the required perl. Show quoted text
> http://nntp.x.perl.org/group/perl.cpan.testers/6129905 : Can't locate Encode.pm > > The latter hits mostly on 5.6.2 systems but could also come from systems > that deliberately decide to run without Encode.
I need to figure out if I should just require Encode or if I ought to do something graceful for these.
Download (untitled) / with headers
text/plain 521b
On Mon Nov 23 15:44:28 2009, GAAS wrote: Show quoted text
> On Mon Nov 23 15:19:59 2009, ANDK wrote:
> > The latter hits mostly on 5.6.2 systems but could also come from
> systems
> > that deliberately decide to run without Encode.
> > I need to figure out if I should just require Encode or if I ought to > do something graceful for > these.
Encode itself won't install on anything less than 5.7.3 these days, so a requirement on Encode will mean that URI itself won't install on anything less than 5.7.3, so neither will LWP et al.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.