Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 51775
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: matisse [...] spamcop.net
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.35
Fixed in: (no value)



Subject: Operation "bool": no method found, argument in overloaded package version
Download (untitled) / with headers
text/plain 500b
On Darwin Kernel Version 10.2.0 Perl v5.10.0 built for darwin-thread-multi-2level Module::Build 0.35 -------snip-------------- % perl Build.PL Checking whether your kit is complete... Looks good Checking prerequisites... Operation "bool": no method found, argument in overloaded package version at /Library/Perl/Updates/5.10.0/Module/Build/Base.pm line 1302. -------snip-------------- If I run under the debugger, I get no error. That is, if I run: perl -d Build.PL and continue, it works.
Download (untitled) / with headers
text/plain 207b
By the way, I looked at https://rt.cpan.org/Ticket/Display.html?id=21496 Operation "eq": no method found and that ticket says they had a problem with File::Temp 0.16. I checked and we have File::temp 0.22
Download (untitled) / with headers
text/plain 331b
I notice that in Module/Build/Version.pm at lines 134-141 a number of operators are overloaded, including 'bool' which uses the vbool() sub defined in that file. So, I trued adding: use Module::Build::Version; to Module/Build/Base.pm and that seems to fix the problem. I'm only guessing here, there might be a deeper issue.
My mistake, adding 'use Module::Build::Version;' did not fix the problem.
Download (untitled) / with headers
text/plain 172b
Looks like it is the use of $^V in triggers a problem. If I add a warn() in Module::build::Base::perl_version() and use $^V in the message then it also triggers an error.
Subject: Re: [rt.cpan.org #51775] Operation "bool": no method found, argument in overloaded package version
Date: Fri, 20 Nov 2009 12:56:42 -0500
To: bug-Module-Build [...] rt.cpan.org
From: David Golden <xdaveg [...] gmail.com>
Download (untitled) / with headers
text/plain 606b
On Fri, Nov 20, 2009 at 11:53 AM, Matisse Enzer via RT <bug-Module-Build@rt.cpan.org> wrote: Show quoted text
>       Queue: Module-Build >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=51775 > > > Looks like it is the use of $^V  in triggers a problem. > If I add a warn() in Module::build::Base::perl_version() and use $^V in the message then it also > triggers an error.
What version of version.pm do you have? If you upgrade version.pm, does the problem go away? If you upgrade Module::Build to 0.35_09, does it go away? The latter is DAGOLDEN/Module-Build-0.35_09.tar.gz on CPAN. Thank you, David
Download (untitled) / with headers
text/plain 509b
On Fri Nov 20 12:57:16 2009, xdaveg@gmail.com wrote: Show quoted text
> What version of version.pm do you have?
0.74 Show quoted text
> > If you upgrade version.pm, does the problem go away?
Yes - I upgraded to 0.78 and the problem went away. Show quoted text
> If you upgrade Module::Build to 0.35_09, does it go away?
I'll skip trying that in light of the upgrade of 'version' Thanks, and I wish I had realized the 'version' in "...overloaded package version ..." was a module. Curses on whoever decided to name it 'version' instead of 'Version' -M
Bug was in version.pm. Closing this ticket.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.