Skip Menu |
 

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id: 51472
Status: resolved
Priority: 0/
Queue: Perl-Dist-Strawberry

People
Owner: Nobody in particular
Requestors: ROBINS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Module::Install-based packages randomly fail configure phase
Running Strawberry Perl 5.10.1 (Oct 2009) and trying to install various CPAN packages using Module::Install. I get this message during the configure stage: fix_up_makefile: Couldn't open Makefile: Invalid argument at inc/Module/Install/Makefile.pm line 243. I assume that it is the open() in line 244 that is the actual error. Module::Install 0.91 seems to be the version in use. The Makefile in question has normal permissions, and the account that tries to install things has administrative rights. If I try to run the cpan XXX over and over again it eventually works and the package is installed (with tests not failing), but I don't feel very confident. Is this a perl bug (related to open()) or a Module::Install bug? Considering I have also seen failing tests I would think that it is a open() bug related to Windows 7 x64. Can anyone reproduce this consistently? These pastes show some of the errors I encountered: http://gist.github.com/232903 http://gist.github.com/232914 I talked to kmx @ #win32@irc.perl.org and he suggested I report this here. -- Robin
Subject: Re: [rt.cpan.org #51472] Module::Install-based packages randomly fail configure phase
Date: Fri, 13 Nov 2009 01:56:23 +1100
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 1.8k
In the past, I have sometimes seen situations in which disk permissions changes lag a bit. We've seen in the past that sometimes a directory delete system call returns true BEFORE the directory has actually gone away. It might be something similar in this case... Adam K 2009/11/13 Robin Smidsrød via RT <bug-Perl-Dist-Strawberry@rt.cpan.org>: Show quoted text
> Thu Nov 12 09:26:31 2009: Request 51472 was acted upon. > Transaction: Ticket created by ROBINS >       Queue: Perl-Dist-Strawberry >     Subject: Module::Install-based packages randomly fail configure phase >   Broken in: (no value) >    Severity: (no value) >       Owner: Nobody >  Requestors: ROBINS@cpan.org >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=51472 > > > > Running Strawberry Perl 5.10.1 (Oct 2009) and trying to install various > CPAN packages using Module::Install. > > I get this message during the configure stage: > > fix_up_makefile: Couldn't open Makefile: Invalid argument at > inc/Module/Install/Makefile.pm line 243. > > I assume that it is the open() in line 244 that is the actual error. > > Module::Install 0.91 seems to be the version in use. > > The Makefile in question has normal permissions, and the account that > tries to install things has administrative rights. > > If I try to run the cpan XXX over and over again it eventually works and > the package is installed (with tests not failing), but I don't feel very > confident. > > Is this a perl bug (related to open()) or a Module::Install bug? > > Considering I have also seen failing tests I would think that it is a > open() bug related to Windows 7 x64. > > Can anyone reproduce this consistently? > > These pastes show some of the errors I encountered: > > http://gist.github.com/232903 > http://gist.github.com/232914 > > I talked to kmx @ #win32@irc.perl.org and he suggested I report this here. > > -- Robin >
Download (untitled) / with headers
text/plain 100b
The changes to Module/Install/Makefile.pm (v0.98) fixed the problem for me. Please test and confirm.
Download (untitled) / with headers
text/plain 263b
On Mon May 31 02:41:20 2010, ROBINS wrote: Show quoted text
> The changes to Module/Install/Makefile.pm (v0.98) fixed the problem for > me. Please test and confirm.
Since I never had this particular problem (I've had similar ones, but not with Module::Install) I'm closing this.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.