Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 51257
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.1708
Fixed in: (no value)



Subject: Introspection missing when "Prerequisite version too low"
Download (untitled) / with headers
text/plain 895b
A recent upload to cpan exposes a bug somewhere that I cannot get hold of. The distro in question is TOKUHIROM/Module-Install-ForC-0.23.tar.gz. Whatever I try, C:R tells me CPAN::Reporter: test results were not valid, Prerequisite version too low. but when I inspect all four prerequisites, namely ExtUtils::MakeMaker, Module::Install, Test::More, and Test::Requires, then I see them all satisfied. Is there a way to find out which dependecies C:R considers unfulfilled? I'm not alone with this problem. Looking into all reports that arrived cpantesters for this distro, C:R has sent only PASS and NA. Not a single FAIL. This is a bit suspicious although it doesn't prove anything. Note also that the total number of results is relatively low, so I suspect other reports were withheld. Downgrading CPAN::Reporter to version 1.02 finally helped me to get a proper FAIL report out the door.
Subject: Re: [rt.cpan.org #51257] Introspection missing when "Prerequisite version too low"
Date: Mon, 9 Nov 2009 23:28:00 -0500
To: bug-CPAN-Reporter [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 1.4k
On Mon, Nov 9, 2009 at 11:01 PM, Andreas Koenig via RT <bug-CPAN-Reporter@rt.cpan.org> wrote: Show quoted text
> but when I inspect all four prerequisites, namely ExtUtils::MakeMaker, > Module::Install, Test::More, and Test::Requires, then I see them all > satisfied. Is there a way to find out which dependecies C:R considers > unfulfilled? > > I'm not alone with this problem. Looking into all reports that arrived > cpantesters for this distro, C:R has sent only PASS and NA. Not a single > FAIL. This is a bit suspicious although it doesn't prove anything. Note > also that the total number of results is relatively low, so I suspect > other reports were withheld.
I hacked up some diagnostics in my live CPAN::Reporter and got this: CPAN::Reporter: test results were not valid, Prerequisite version too low: requires: Module Need Have ------------------- ---- ------- ExtUtils::MakeMaker 6.42 6.55_02 ! Module::Install 0 broken Test::More 0 0.92 Test::Requires 0 0.03 configure_requires: Module Need Have ------------------- ---- ------- ExtUtils::MakeMaker 6.42 6.55_02 I haven't had a chance to diagnose what's going on. "broken" means an eval "require Module::Install" failed when run in a subprocess with the same PERL5LIB as Makefile.PL/make would be run. At a mininum, these "not valid" reports should probably include the prereq report diagnostic like I have above. -- David
CC: ANDK [...] cpan.org
Subject: Re: [rt.cpan.org #51257] Introspection missing when "Prerequisite version too low"
Date: Tue, 10 Nov 2009 07:21:36 +0100
To: bug-CPAN-Reporter [...] rt.cpan.org
From: andreas.koenig.7os6VVqR [...] franz.ak.mind.de (Andreas J. Koenig)
Download (untitled) / with headers
text/plain 2.3k
Show quoted text
>>>>> On Mon, 09 Nov 2009 23:28:35 -0500, "David Golden via RT" <bug-CPAN-Reporter@rt.cpan.org> said:
Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=51257 > > On Mon, Nov 9, 2009 at 11:01 PM, Andreas Koenig via RT > <bug-CPAN-Reporter@rt.cpan.org> wrote:
>> but when I inspect all four prerequisites, namely ExtUtils::MakeMaker, >> Module::Install, Test::More, and Test::Requires, then I see them all >> satisfied. Is there a way to find out which dependecies C:R considers >> unfulfilled? >> >> I'm not alone with this problem. Looking into all reports that arrived >> cpantesters for this distro, C:R has sent only PASS and NA. Not a single >> FAIL. This is a bit suspicious although it doesn't prove anything. Note >> also that the total number of results is relatively low, so I suspect >> other reports were withheld.
Show quoted text
> I hacked up some diagnostics in my live CPAN::Reporter and got this:
Show quoted text
> CPAN::Reporter: test results were not valid, Prerequisite version too low: > requires:
Show quoted text
> Module Need Have > ------------------- ---- ------- > ExtUtils::MakeMaker 6.42 6.55_02 > ! Module::Install 0 broken > Test::More 0 0.92 > Test::Requires 0 0.03
Show quoted text
> configure_requires:
Show quoted text
> Module Need Have > ------------------- ---- ------- > ExtUtils::MakeMaker 6.42 6.55_02
Show quoted text
> I haven't had a chance to diagnose what's going on. "broken" means an > eval "require Module::Install" failed when run in a subprocess with > the same PERL5LIB as Makefile.PL/make would be run.
That is due to the very special magic in Module::Install. It says % /usr/local/perl-5.8.7-threaded/bin/perl "-Iinc" -MModule::Install -de 1 Loading DB routines from perl5db.pl version 1.28 Editor support available. Enter h or `h h' for help, or `man perldebug' for more help. Please invoke Module::Install with: use inc::Module::Install; not: use Module::Install; Compilation failed in require. at -e line 0 main::BEGIN() called at inc/Module/Install.pm line 0 eval {...} called at inc/Module/Install.pm line 0 BEGIN failed--compilation aborted. at -e line 0 I wonder if you could drop trying to load any of the prerequisites? Isn't just looking at the available versions more adequate? -- andreas
Subject: Re: [rt.cpan.org #51257] Introspection missing when "Prerequisite version too low"
Date: Tue, 10 Nov 2009 06:22:22 -0500
To: bug-CPAN-Reporter [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 1003b
On Tue, Nov 10, 2009 at 1:21 AM, (Andreas J. Koenig) via RT <bug-CPAN-Reporter@rt.cpan.org> wrote: Show quoted text
> That is due to the very special magic in Module::Install. It says
Of course! "broken" is quite correct for Module::Install. Show quoted text
> I wonder if you could drop trying to load any of the prerequisites? > Isn't just looking at the available versions more adequate?
I think not. The whole idea is that it's not enough for prereq to exist, it must be loadable. There are cases where Foo depends on Bar and an upgrade to Bar break Foo compiling. CPAN::Reporter::PrereqCheck gets to test prerequisites *exactly* the way *.PL does. This is a difference between CPAN.pm and CPAN::Reporter. CPAN.pm just needs to care that the module is installed. CPAN::Reporter has a higher standard of not reporting FAIL unless it is *sure* that the dependency is actually loadable. I think I'll just wind up special-casing Module::Install. I wonder s/Module::Install/inc::Module::Install/ would be sufficient. -- David
CC: ANDK [...] cpan.org
Subject: Re: [rt.cpan.org #51257] Introspection missing when "Prerequisite version too low"
Date: Tue, 10 Nov 2009 20:47:10 +0100
To: bug-CPAN-Reporter [...] rt.cpan.org
From: andreas.koenig.7os6VVqR [...] franz.ak.mind.de (Andreas J. Koenig)
Download (untitled) / with headers
text/plain 563b
Show quoted text
>>>>> On Tue, 10 Nov 2009 06:22:59 -0500, "David Golden via RT" <bug-CPAN-Reporter@rt.cpan.org> said:
Show quoted text
> This is a difference between CPAN.pm and CPAN::Reporter. CPAN.pm just > needs to care that the module is installed. CPAN::Reporter has a > higher standard of not reporting FAIL unless it is *sure* that the > dependency is actually loadable.
Yeah, agree, this sounds very correct. Show quoted text
> I think I'll just wind up special-casing Module::Install. I wonder > s/Module::Install/inc::Module::Install/ would be sufficient.
I think it is. -- andreas
Download (untitled) / with headers
text/plain 142b
I've patched CPAN::Reporter::PrereqCheck in the repo to substitute inc::Module::Install for Module::Install for prerequisite checks. -- David


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.