Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 51256
Status: open
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: jmcnamara [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: Magic Error number check reports falsely on non-read $^E and $!
Download (untitled) / with headers
text/plain 687b
Perl::MinimumVersion cantains a _bugfix_magic_errno check that says if the magic variable $^E and $! appear in the same document then the perl verison required is 5.8.3. The _bugfix_magic_errno check seems to refer to the $^E bugfix in perl 5.8.3 which relates to *reading* $^E. http://search.cpan.org/~nwclark/perl-5.8.3/pod/perl583delta.pod#Selected_Bug_Fixes The check is overly restrictive in a case such as the following where $^E isn't read: $ cat local.pl local ($^E, $!); $ perlver local.pl | grep 'Minimum version' | Minimum version of perl : v5.8.3 The $^E variable was added in perl 5.004, so the above snippet should be reported at that version. John. --
Ping. Could we please get this fixed or removed?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.