Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 5111
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: MIROD [...] cpan.org
Requestors: blair [...] orcaware.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 3.12
Fixed in: 3.13



Subject: XML::Twig 3.12 make test fails on 5.8.0 and older
Download (untitled) / with headers
text/plain 2.4k
Hello, Running make test with XML::Twig runs fine with perl 5.8.2 and newer, but with perl 5.8.0 I get this message on RedHat 9; t/test5.............................ok t/test_additional...................Tie::IxHash not available: skipping 7 tests your version of expat/XML::Parser has a broken xml_escape method xml_escape( '<elt>toto</elt>') should be '&lt;elt>toto&lt;/elt>' but is '&lt;elt>toto</elt>' instead your version of expat/XML::Parser has a broken xml_escape method xml_escape( '<elt>toto</elt>', 'o') should be '&lt;elt>t&#x6F;t&#x6F;&lt;/elt>' but is '&lt;elt>t&#x6F;t&#x6F;</elt>' instead Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3246. Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3246. Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3246. safe: expected: '<?xml version="1.0" encoding="UTF-8"?> <doc>&#233;t&#233;</doc>' got : '<?xml version="1.0" encoding="UTF-8"?> <doc>&#233;té</doc>' Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3253. Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3253. Malformed UTF-8 character (unexpected continuation byte 0xa9, with no preceding start byte) in substitution iterator at /export/home1/blair/.cpan/XML-Twig-3.12/blib/lib/XML/Twig.pm line 3253. safe_hex: expected: '<?xml version="1.0" encoding="UTF-8"?> <doc>&#xe9;t&#xe9;</doc>' got : '<?xml version="1.0" encoding="UTF-8"?> <doc>&#xe9;té</doc>' need Text::Iconv for those tests: skipping 3 tests need Unicode::Map8 and Unicode::String for those tests: skipping 3 tests require XML::Handler::YAWriter: skipping 3 tests XML::SAX::Writer not available: skipping 3 tests t/test_additional...................FAILED tests 326-327 Failed 2/441 tests, 99.55% okay t/test_attregexp_cond...............ok I even just recompiled and reinstalled my XML::Parser and I'm getting the same failure. Best, Blair
Download (untitled) / with headers
text/plain 200b
Hi, Indeed, there is a problem in 5.8.0 and only in 5.8.0. Could you check if the current dv version at http://xmltwig.com/xmltwig/XML-Twig-3.13.tar.gz fixes the problem for you? Thanks __ Mirod
Date: Wed, 10 Mar 2004 18:46:39 +0100 (CET)
From: Michel Rodriguez <mirod [...] xmltwig.com>
To: via RT <bug-XML-Twig [...] rt.cpan.org>
Subject: Re: [xmltwig] [cpan #5111] XML::Twig 3.12 make test fails on 5.8.0 and older
RT-Send-Cc:
Download (untitled) / with headers
text/plain 366b
Could you test it with 3.13 or, even better, with the development version at http://xmltwig.com/xmltwig/ ? I should release it later this week so you might as well try it beforehand. Plus it will report some more information about your configuration. If it still fails try upgrading expat BTW Thank you -- Michel Rodriguez Perl &amp; XML http://www.xmltwig.com


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.